Reynold Xin created SPARK-9430:
----------------------------------
Summary: Rename IntervalType to CalendarInterval
Key: SPARK-9430
URL: https://issues.apache.org/jira/browse/SPARK-9430
Project: Spark
Issue Type: Sub-task
Components: SQL
Reporter: Reynold Xin
Based on offline discussion with [~marmbrus].
In 1.6, I think we should just create a TimeInterval type, which stores only
the interval in terms of number of microseconds. TimeInterval can then be
comparable.
In 1.5, we should rename the existing IntervalType to CalendarInterval, so we
won't have name clashes in 1.6.
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)
---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]