[ 
https://issues.apache.org/jira/browse/STORM-1605?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Jungtaek Lim resolved STORM-1605.
---------------------------------
       Resolution: Fixed
         Assignee: Cody
    Fix Version/s:     (was: 0.10.1)

> storm shell script should use /bin/env python to check python version
> ---------------------------------------------------------------------
>
>                 Key: STORM-1605
>                 URL: https://issues.apache.org/jira/browse/STORM-1605
>             Project: Apache Storm
>          Issue Type: Bug
>          Components: storm-core
>    Affects Versions: 0.10.1, 2.0.0
>         Environment: RHEL 5.7
>            Reporter: Cody
>            Assignee: Cody
>             Fix For: 2.0.0
>
>   Original Estimate: 120h
>  Remaining Estimate: 120h
>
> Currently storm script uses /usr/bin/python2.6 and /usr/bin/python to check 
> python version, however, RHEL5 ships with python2.4 by default, so when users 
> upgrade python to 2.7.5 without changing /usr/bin/python to 2.7.5 python 
> binary, storm will fail to start since it thinks it's using python2.4.
> It would be better to use /bin/env python to detect python version instead.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Reply via email to