[ 
https://issues.apache.org/jira/browse/TEZ-3901?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16390550#comment-16390550
 ] 

Eric Wohlstadter commented on TEZ-3901:
---------------------------------------

[~harishjp]

I see the same behavior, you can't explicitly specify -Phadoop27. This is not 
related to this patch.
I think it's ok, because BUILDING.txt doesn't say that you should ever specify 
-Phadoop27.

FOR 2.7.0
{code}
$ mvn clean install
$ ls tez-dist/target/tez-0.9.2-SNAPSHOT/lib/ | grep jersey
jersey-client-1.9.jar
jersey-core-1.9.jar
jersey-guice-1.9.jar
jersey-json-1.9.jar
{code}

FOR 2.8.2
{code}
$ mvn -Phadoop28 -P\!hadoop27 -Dhadoop.version=2.8.2 clean install
$ ls tez-dist/target/tez-0.9.2-SNAPSHOT/lib/ | grep jersey
jersey-client-1.9.jar
jersey-core-1.9.jar
jersey-guice-1.9.jar
jersey-json-1.9.jar
{code}

FOR 3.0.0
{code}
$ mvn -Phadoop3 -P\!hadoop27 -Dhadoop.version=3.0.0 clean install
$ ls tez-dist/target/tez-0.9.2-SNAPSHOT/lib/ | grep jersey
jersey-client-1.19.jar
jersey-core-1.19.jar
jersey-guice-1.19.jar
jersey-json-1.19.jar
jersey-servlet-1.19.jar
{code}


 

> Add hadoop3 profile for upgrade to Jersey 1.19
> ----------------------------------------------
>
>                 Key: TEZ-3901
>                 URL: https://issues.apache.org/jira/browse/TEZ-3901
>             Project: Apache Tez
>          Issue Type: Improvement
>            Reporter: Eric Wohlstadter
>            Assignee: Eric Wohlstadter
>            Priority: Major
>         Attachments: TEZ-3901.1.patch, TEZ-3901.2.patch
>
>
> From [~harishjp]:
> "DAGAppMaster fails to start when using hadoop3 and ATSv15, because 
> TimelineWriter has been changed to use jersey-client 1.19 in hadoop3, but tez 
> packages jersey-client 1.9 with it. There are incompatible changes between 
> them, so we cannot upgrade to 1.19 for all versions, it should be 1.9 in 
> older hadoop and 1.19 in hadoop3."
>  
> This patch includes some copy and paste of the hadoop28 profile to a hadoop3 
> profile. Maven doesn't include anything like "profile inheritance".



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to