[
https://issues.apache.org/jira/browse/TEZ-3978?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17386507#comment-17386507
]
Yongjun Zhang commented on TEZ-3978:
------------------------------------
HI [~jeagles] [~jlowe],
Thanks for your work here. I'm seeing similar issue with Hadoop,
{code:java}
FATAL [main] org.apache.hadoop.mapreduce.v2.app.MRAppMaster: Error starting
MRAppMaster
org.apache.hadoop.yarn.exceptions.YarnRuntimeException:
java.net.SocketException: Call From 0.0.0.0 to null:0 failed on socket
exception: java.net.SocketException: Invalid argument; For more details see:
http://wiki.apache.org/hadoop/SocketException
at
org.apache.hadoop.yarn.factories.impl.pb.RpcServerFactoryPBImpl.getServer(RpcServerFactoryPBImpl.java:138)
at
org.apache.hadoop.yarn.ipc.HadoopYarnProtoRPC.getServer(HadoopYarnProtoRPC.java:65)
at
org.apache.hadoop.mapreduce.v2.app.client.MRClientService.serviceStart(MRClientService.java:121)
at
org.apache.hadoop.service.AbstractService.start(AbstractService.java:194)
at
org.apache.hadoop.mapreduce.v2.app.MRAppMaster.serviceStart(MRAppMaster.java:1398)
at
org.apache.hadoop.service.AbstractService.start(AbstractService.java:194)
at
org.apache.hadoop.mapreduce.v2.app.MRAppMaster$6.run(MRAppMaster.java:1872)
at java.security.AccessController.doPrivileged(Native Method)
at javax.security.auth.Subject.doAs(Subject.java:422)
at
org.apache.hadoop.security.UserGroupInformation.doAs(UserGroupInformation.java:1893)
at
org.apache.hadoop.mapreduce.v2.app.MRAppMaster.initAndStartAppMaster(MRAppMaster.java:1868)
at
org.apache.hadoop.mapreduce.v2.app.MRAppMaster.main(MRAppMaster.java:1799)
{code}
wonder if the solution you put here fixed the problem or made it show a "
hostname resolution has failed on that node." symptom? See your comment:
https://issues.apache.org/jira/browse/TEZ-3978?focusedCommentId=16578922&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-16578922
I'm thinking about trying the same solution you did here. Thanks a lot.
> DAGClientServer Socket exception when localhost name lookup failures
> --------------------------------------------------------------------
>
> Key: TEZ-3978
> URL: https://issues.apache.org/jira/browse/TEZ-3978
> Project: Apache Tez
> Issue Type: Bug
> Reporter: Jonathan Turner Eagles
> Assignee: Jonathan Turner Eagles
> Priority: Major
> Fix For: 0.9.2, 0.10.0
>
> Attachments: TEZ-3978.001.patch, TEZ-3978.002.patch
>
>
> Call From 0.0.0.0 to null:0 failed on socket exception:
> java.net.SocketException: Invalid argument
> {code}
> 2018-08-10 21:19:55,523 [ERROR] [ServiceThread:DAGClientRPCServer]
> |client.DAGClientServer|: Failed to start DAGClientServer:
> java.net.SocketException: Call From 0.0.0.0 to null:0 failed on socket
> exception: java.net.SocketException: Invalid argument; For more details see:
> http://wiki.apache.org/hadoop/SocketException
> at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
> at
> sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
> at
> sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
> at java.lang.reflect.Constructor.newInstance(Constructor.java:423)
> at org.apache.hadoop.net.NetUtils.wrapWithMessage(NetUtils.java:804)
> at org.apache.hadoop.net.NetUtils.wrapException(NetUtils.java:777)
> at org.apache.hadoop.ipc.Server.bind(Server.java:563)
> at org.apache.hadoop.ipc.Server$Listener.<init>(Server.java:958)
> at org.apache.hadoop.ipc.Server.<init>(Server.java:2657)
> at org.apache.hadoop.ipc.RPC$Server.<init>(RPC.java:968)
> at
> org.apache.hadoop.ipc.ProtobufRpcEngine$Server.<init>(ProtobufRpcEngine.java:367)
> at
> org.apache.hadoop.ipc.ProtobufRpcEngine.getServer(ProtobufRpcEngine.java:342)
> at org.apache.hadoop.ipc.RPC$Builder.build(RPC.java:810)
> at
> org.apache.tez.dag.api.client.DAGClientServer.createServer(DAGClientServer.java:134)
> at
> org.apache.tez.dag.api.client.DAGClientServer.serviceStart(DAGClientServer.java:82)
> at
> org.apache.hadoop.service.AbstractService.start(AbstractService.java:193)
> at
> org.apache.tez.dag.app.DAGAppMaster$ServiceWithDependency.start(DAGAppMaster.java:1909)
> at
> org.apache.tez.dag.app.DAGAppMaster$ServiceThread.run(DAGAppMaster.java:1930)
> Caused by: java.net.SocketException: Invalid argument
> at sun.nio.ch.Net.bind0(Native Method)
> at sun.nio.ch.Net.bind(Net.java:433)
> at sun.nio.ch.Net.bind(Net.java:425)
> at
> sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:223)
> at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:74)
> at org.apache.hadoop.ipc.Server.bind(Server.java:553)
> ... 11 more
> {code}
--
This message was sent by Atlassian Jira
(v8.3.4#803005)