[
https://issues.apache.org/jira/browse/TS-1888?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]
James Peach updated TS-1888:
----------------------------
Fix Version/s: 3.5.0
Push out to 3.5.0.
> clean up ink_sock and SocketManager
> -----------------------------------
>
> Key: TS-1888
> URL: https://issues.apache.org/jira/browse/TS-1888
> Project: Traffic Server
> Issue Type: Improvement
> Components: Core, Portability
> Reporter: James Peach
> Fix For: 3.5.0
>
>
> ink_sock.cc and SocketManager.cc both have random assortment of simple
> wrappers around socket and file descriptor APIs. Its confusing for them to be
> split across 2 locations and in some places, we don't even use the wrapper.
> We should kill SocketManager and use ink_sock exclusively. We should use a
> consistent naming convention (ie. we don't need both safe_bind and ink_bind).
> We should use the wrappers everywhere across the code base (or remove the
> wrapper if it makes sense).
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira