[
https://issues.apache.org/jira/browse/TS-2158?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13750535#comment-13750535
]
Phil Sorber commented on TS-2158:
---------------------------------
He was using <phi> (as clarified in IRC) and it was picking the IPv6 link local
IP because this function didn't properly identify it as non-routable.
There is still the further question (which I think we decided yes to) of
whether we should give IPv6 preference anyway, since that is the standard when
dealing with dual stack.
But I have been thinking about this a little more, and the code separates out
loopback as well, so maybe this should be renamed to ats_is_ip_private() and
then we should also add ats_is_ip_linklocal() and then we can make
ats_is_ip_nonroutable() wrap all 3 of those. Thoughts?
> ats_is_ip_nonroutable does not properly handle link local addresser nor v6
> addresses
> ------------------------------------------------------------------------------------
>
> Key: TS-2158
> URL: https://issues.apache.org/jira/browse/TS-2158
> Project: Traffic Server
> Issue Type: Bug
> Affects Versions: 4.0.0
> Reporter: Phil Sorber
> Assignee: Phil Sorber
> Fix For: 4.1.0
>
> Attachments: TS-2158.patch, TS-2158_v2.patch
>
>
> We need to augment ats_is_ip_nonroutable so that it also returns that link
> local addresses are non-routable and also handle v6 private and link local
> addresses.
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira