[
https://issues.apache.org/jira/browse/TS-2160?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13750818#comment-13750818
]
Phil Sorber commented on TS-2160:
---------------------------------
Yes, I want to remove it, but I think we need the replacements. We need to be
able to order for precedence. Maybe they don't need their own function in
ink_inet.h, but I think that is probably some bike-shedding and we can at least
move in the right direction by doing what I propose in this ticket.
> Split ats_is_ip_nonroutable into two separate functions
> -------------------------------------------------------
>
> Key: TS-2160
> URL: https://issues.apache.org/jira/browse/TS-2160
> Project: Traffic Server
> Issue Type: Improvement
> Reporter: Phil Sorber
>
> We should create ats_is_ip_private and ats_is_ip_linklocal then replace usage
> of ats_is_ip_nonroutable with them and remove it.
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira