Huaping Gu commented on TS-4973:

Hi all,
after remove the autoreconf -if, docker imag ebuild green now.
#RUN autoreconf -if /trafficserver-6.2.0/configure.ac

This maybe some reason about the autoconfig in 14.04 ubuntu.  It is NOT issue 
on ATS 6.2.0 I believe. Close this JIRA.

root@f937b8fe5ab7:/opt# md5sum /usr/lib/x86_64-linux-gnu/libtcl8.6.so
5e4e322fe98b26cb459bde1fdea75b9c  /usr/lib/x86_64-linux-gnu/libtcl8.6.so
root@f937b8fe5ab7:/opt# ls -l /usr/lib/x86_64-linux-gnu/libtcl8.6.so
-rw-r--r-- 1 root root 1668272 Jan  2  2014 
root@f937b8fe5ab7:/opt# objdump -T /usr/lib/x86_64-linux-gnu/libtcl8.6.so | 
grep Tcl_NextHashEntry
00000000000c9090 g    DF .text0000000000000065  Base        Tcl_NextHashEntry

#failed test_mime dependency
libtool: link: c++ -std=c++11 -g -pipe -Wall -O3 
-feliminate-unused-debug-symbols -fno-strict-aliasing -Wno-invalid-offsetof 
-mcx16 -rdynamic -o .libs/test_mime test_mime.o  -L. -lhdrs 
../../lib/ts/.libs/libtsutil.so ../../iocore/eventsystem/libinkevent.a 
../../lib/records/librecords_p.a ../../mgmt/.libs/libmgmt_p.a 
../../proxy/shared/libUglyLogStubs.a -lhwloc -lcap -lpcre -lz -lcrypt -lpthread 
-ldl -lxml2 -Wl,-rpath -Wl,/opt/ats/lib

#success test_mime dependency
libtool: link: c++ -std=c++11 -g -pipe -Wall -O3 
-feliminate-unused-debug-symbols -fno-strict-aliasing -Wno-invalid-offsetof 
-mcx16 -rdynamic -o .libs/test_mime test_mime.o  -L. -lhdrs 
../../lib/ts/.libs/libtsutil.so -lssl -lcrypto -ltcl8.6 -lresolv 
../../iocore/eventsystem/libinkevent.a ../../lib/records/librecords_p.a 
../../mgmt/.libs/libmgmt_p.a ../../proxy/shared/libUglyLogStubs.a -lhwloc -lcap 
-lpcre -lz -lcrypt -lpthread -ldl -lxml2 -Wl,-rpath -Wl,/opt/ats/lib

> ubuntu 14.04 ATS 6.2.0 proxy/hdrs undefined reference to symbol 
> 'Tcl_NextHashEntry'
> -----------------------------------------------------------------------------------
>                 Key: TS-4973
>                 URL: https://issues.apache.org/jira/browse/TS-4973
>             Project: Traffic Server
>          Issue Type: Bug
>          Components: Build
>    Affects Versions: 6.2.0
>            Reporter: Huaping Gu
> build failed in Docker, on image ubuntu 14.04, 14.04.5
> add explicit command to install tcl, still failed
> "RUN apt-get install -y libtcl8.6"
> Following are stack trace of the error message. Similar error found in TS-4521
> ============================================================
> Making check in proxy/hdrs
> make[1]: Entering directory `/proxy/hdrs'
> make  test_mime
> make[2]: Entering directory `/proxy/hdrs'
>   CXX      test_mime.o
>   CXXLD    test_mime
> /usr/bin/ld: ./libhdrs.a(HttpCompat.o): undefined reference to symbol 
> 'Tcl_NextHashEntry'
> //usr/lib/x86_64-linux-gnu/libtcl8.6.so: error adding symbols: DSO missing 
> from command line
> collect2: error: ld returned 1 exit status
> make[2]: *** [test_mime] Error 1
> make[2]: Leaving directory `/proxy/hdrs'
> make[1]: *** [check-am] Error 2
> make[1]: Leaving directory `/proxy/hdrs'
> make: *** [check-recursive] Error 1
> The command '/bin/sh -c make check' returned a non-zero code: 2
> ==========================
> Append: Same source code build success on Mac (10.12)

This message was sent by Atlassian JIRA

Reply via email to