[
https://issues.apache.org/jira/browse/TS-5049?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]
Bryan Call updated TS-5049:
---------------------------
Fix Version/s: 7.1.0
> Parent.config keynames are confusing
> ------------------------------------
>
> Key: TS-5049
> URL: https://issues.apache.org/jira/browse/TS-5049
> Project: Traffic Server
> Issue Type: Improvement
> Components: Parent Proxy
> Reporter: Miles Libbey
> Fix For: 7.1.0
>
>
> In parent.config, we have a series of key names that are either confusing, or
> have been expanded well beyond what the name implies:
> - round_robin. This now describes a selection strategy.
> - parent. Origins can be described here too. Not sure what a good descriptor
> would be.
> - parent_is_proxy describes how the request will be made from the child node
> -- eg, 'true,' means the request will be a proxy style request (GET
> http://example.com/foo); 'false' means a traditional style request (GET
> /foo\n Host: example.com)
> In addition, there are several options that only apply when other settings
> are used. For instance, secondary_parent only applies to the consistent_hash
> strategy. Similarly, today, "qstring" only applies to consistent_hash, as the
> URI is not considered for any other existing selection strategy.
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)