On 04/13/18 04:50, Antonio Scuri wrote:
   I'm sorry. I don't know.

   I even implemented a new internal function to send a key using a better
GTK interface, but it changes nothing. "In" works ok, and "Out" does not

   I committed to the SVN anyway.


2018-04-12 11:46 GMT-03:00 許永寬 <nagahiro....@gmail.com>:

Dear Scuri:

I test below code to try to send key to other dialog,
In Win7, it works good, but in Linux Mint 18.3, the "Send Hello Out" can't
How should I need modify my code to work in Linux Mint?

     IupSetCallback( button1, "ACTION", cast(Icallback) &button1_ACTION );

     Ihandle* text1 = IupText( null );
     IupSetAttribute( text1, "EXPAND", "YES" );
     IupSetAttribute( text1, "NAME", "TEXT1" );
     IupSetAttribute( text1, "MULTILINE", "YES" );

     Ihandle* hBox1 = IupHbox( button, button1, null );
     Ihandle* vBox1 = IupVbox( hBox1, text1, null );

     IupAppend( subDialog, vBox1 );

     IupShow( subDialog );


Iup-users mailing list


As mentioned before, I've managed to get all of IM, CD and IUP working
under Mint 18.3.  However, my testing has been minimal, and has been
constrained to "toy" Lua scripts.

At the moment, I'm battling with various personal circumstances, and so
am not sharing (MIT license) my code yet; also, my difficulties have
impeded me from bringing up my code to the high standards that I have
been vocal to others about.

At present, there's significant changes to IUP almost daily; I'm
stepping back for the moment, trying to concentrate on improving my
own code (mainly documentation, at this point), and am waiting for IUP
to settle down somewhat before releasing my infrastructure for public

I believe that my framework would make it easier to change central
library code (e.g. perhaps add trace commands), and try it out in a
local, private workspace, without needing system installation.

The entire framework is in Lua, except for one Bash script.

Sadly, there are some anachronisms/idiosyncrasies in the way the
suite of scripts has evolved (over possibly five years), and due
to the difficulties hinted at above, I'm focussing on documenting
what's there and is working well, rather than make the entire
framework run more neatly.


In the short term, I'm sitting back now, and tracking repository
changes; I may release an IUP-under-GNU/Linux-Mint-18.3 warnings
summary in the near future (mainly as there have been some code
changes), but otherwise being fairly quiet.

I haven't tried producing an executable with the Tecgraf libraries,
partially because I've strenuously tried to stay clear of building
Lua in my framework, relying instead on Lua being the base, and
require()ing other components as shared objects.


*** Given this Lua-at-the-base starting point, can you generate
a Lua script that demonstrates the problem?  If so, I can plug it
into my framework, and see if I can find anything.

My reasons for this request is that, both at the Lua level and at
the Tecgraf level, I've never been involved in other
teams/projects, and, as such, have a poorer knowledge base to
start from when looking for bugs.

Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
Iup-users mailing list

Reply via email to