On Mon, 24 Dec 2007 08:52:23 -0500 "Efren Bravo" <[EMAIL PROTECTED]> wrote:
> Hi, > > I've a freeBSD6.2 with jabberd 2.1.18 and mysql (client and server) > 5.0.45_1. > > First time I installed it, the router started to disconnect > continually, writing the message into the logs: > Thu Dec 6 09:17:18 2007 [notice] [127.0.0.1, port=62581] error: XML > parse error (not well-formed (invalid token)) > > Searching on Internet I found some people with the same problem, the > solution was to check the character set of the mySQL. I stopped the > mySQL, changed all variables to utf8 and started it again, also > checked the character set of every table and only the vcard had > latin1, so changed it to utf8. > > Now, I've achieved that the jabberd works ok while it has connected > users. The next day (without connected users), when, they try to make > their connections, they cann't and in the router logs appears the > same error message (XML parse ...). The error has the datetime of the > first connection intent. > > What else can I check in jabberd? > > Thanks in advance.... Did you set "default-character-set = utf8" in either the [client] or the [jabberd] section of your MySQL config? That's what fixed it for me. See http://jabberd2.xiaoka.com/ticket/177. Regards, harry
signature.asc
Description: PGP signature
_______________________________________________ Jabberd2 mailing list [email protected] http://lists.xiaoka.com/listinfo.cgi/jabberd2-xiaoka.com
