From: Andreas Koelbl <Andreas Koelbl [email protected]>
Those patches are mostly cleanups:
- consistent naming of uart components like config and filenames
- consistent naming of stubs
- move panic_cpu variables to the appropriate position
- Documentation of the hypervisor configuration
since v1:
- only clean up UART code and don't touch the jailhouse configuration
- rebase to next (arm64 was merged in the meanwhile)
Andreas
Andreas Kölbl (6):
Rename uart_pl011.h to uart-pl011.h and dbg-write-pl011.c to
uart-pl011.c
arm: Rename debug.h to uart.h
arm: Rename CONFIG_UART_OXPCIE952 to CONFIG_SERIAL_OXPCIE952
arm: rename smp.c to smp-stubs.c
core: Move panic_cpu and panic_in_progress to control.c
Documentation: how to configure jailhouse
Documentation/hypervisor-configuration.txt | 60 ++++++++++++++++++++++
hypervisor/arch/arm-common/dbg-write.c | 3 +-
.../arm-common/{dbg-write-pl011.c => uart-pl011.c} | 2 +-
hypervisor/arch/arm/Makefile | 4 +-
hypervisor/arch/arm/include/asm/uart-8250-dw.h | 2 +-
.../arm/include/asm/{uart_pl011.h => uart-pl011.h} | 2 +-
hypervisor/arch/arm/include/asm/uart-tegra.h | 2 +-
.../arch/arm/include/asm/{debug.h => uart.h} | 6 +--
hypervisor/arch/arm/{smp.c => smp-stubs.c} | 0
hypervisor/arch/x86/dbg-write.c | 2 +-
hypervisor/control.c | 3 ++
hypervisor/include/jailhouse/control.h | 3 ++
hypervisor/include/jailhouse/printk.h | 3 --
hypervisor/printk.c | 4 +-
inmates/demos/x86/32-bit-demo.c | 2 +-
inmates/demos/x86/apic-demo.c | 2 +-
inmates/demos/x86/e1000-demo.c | 2 +-
inmates/demos/x86/ioapic-demo.c | 2 +-
inmates/demos/x86/pci-demo.c | 2 +-
inmates/demos/x86/smp-demo.c | 2 +-
inmates/demos/x86/tiny-demo.c | 2 +-
inmates/lib/arm/printk.c | 2 +-
inmates/lib/arm/uart-pl011.c | 2 +-
inmates/lib/x86/printk.c | 2 +-
24 files changed, 89 insertions(+), 27 deletions(-)
create mode 100644 Documentation/hypervisor-configuration.txt
rename hypervisor/arch/arm-common/{dbg-write-pl011.c => uart-pl011.c} (94%)
rename hypervisor/arch/arm/include/asm/{uart_pl011.h => uart-pl011.h} (99%)
rename hypervisor/arch/arm/include/asm/{debug.h => uart.h} (86%)
rename hypervisor/arch/arm/{smp.c => smp-stubs.c} (100%)
--
2.10.0
--
You received this message because you are subscribed to the Google Groups
"Jailhouse" group.
To unsubscribe from this group and stop receiving emails from it, send an email
to [email protected].
For more options, visit https://groups.google.com/d/optout.