Branch: refs/heads/next
  Home:   https://github.com/siemens/jailhouse
  Commit: 25b4ae5fd5edffadbe0ab4a95046a4f5b9b8ca2b
      
https://github.com/siemens/jailhouse/commit/25b4ae5fd5edffadbe0ab4a95046a4f5b9b8ca2b
  Author: Andreas Kölbl <[email protected]>
  Date:   2016-10-29 (Sat, 29 Oct 2016)

  Changed paths:
    R hypervisor/arch/arm-common/dbg-write-pl011.c
    A hypervisor/arch/arm-common/uart-pl011.c
    M hypervisor/arch/arm/Makefile
    A hypervisor/arch/arm/include/asm/uart-pl011.h
    R hypervisor/arch/arm/include/asm/uart_pl011.h
    M hypervisor/arch/arm64/Makefile
    M inmates/lib/arm/uart-pl011.c

  Log Message:
  -----------
  arm: Rename uart_pl011.h to uart-pl011.h and dbg-write-pl011.c to uart-pl011.c

Makes naming consistent.

Signed-off-by: Andreas Kölbl <[email protected]>
[Jan: adjusted ARM64 build as well]
Signed-off-by: Jan Kiszka <[email protected]>


  Commit: 88fbb4b321fb5eb4312b580d521263968c47b2d5
      
https://github.com/siemens/jailhouse/commit/88fbb4b321fb5eb4312b580d521263968c47b2d5
  Author: Andreas Kölbl <[email protected]>
  Date:   2016-10-29 (Sat, 29 Oct 2016)

  Changed paths:
    M hypervisor/arch/arm-common/dbg-write.c
    R hypervisor/arch/arm/include/asm/debug.h
    M hypervisor/arch/arm/include/asm/uart-8250-dw.h
    M hypervisor/arch/arm/include/asm/uart-pl011.h
    M hypervisor/arch/arm/include/asm/uart-tegra.h
    A hypervisor/arch/arm/include/asm/uart.h
    M inmates/lib/arm/printk.c

  Log Message:
  -----------
  arm: Rename debug.h to uart.h

This header is only included by concrete uart drivers. Furthermore, it
only declares the the abstract uart_chip structure. Naming it debug.h
might be misleading.

Signed-off-by: Andreas Kölbl <[email protected]>
Signed-off-by: Jan Kiszka <[email protected]>


  Commit: b8ec7f97122b7b21927b689f01673dba25a409a8
      
https://github.com/siemens/jailhouse/commit/b8ec7f97122b7b21927b689f01673dba25a409a8
  Author: Andreas Kölbl <[email protected]>
  Date:   2016-10-29 (Sat, 29 Oct 2016)

  Changed paths:
    M hypervisor/arch/x86/dbg-write.c
    M inmates/demos/x86/32-bit-demo.c
    M inmates/demos/x86/apic-demo.c
    M inmates/demos/x86/e1000-demo.c
    M inmates/demos/x86/ioapic-demo.c
    M inmates/demos/x86/pci-demo.c
    M inmates/demos/x86/smp-demo.c
    M inmates/demos/x86/tiny-demo.c
    M inmates/lib/x86/printk.c

  Log Message:
  -----------
  arm: Rename CONFIG_UART_OXPCIE952 to CONFIG_SERIAL_OXPCIE952

All configuration parameters for serial drivers are prefixed by CONFIF_UART_*,
except of OXPCIE952. In order to get consistency, CONFIG_UART_OXPCIE952 should
be renamed to CONFIG_SERIAL_OXPCIE952

Signed-off-by: Andreas Kölbl <[email protected]>
Signed-off-by: Jan Kiszka <[email protected]>


  Commit: a8ead233634f2855f60902d69ab59a1784eaf8a3
      
https://github.com/siemens/jailhouse/commit/a8ead233634f2855f60902d69ab59a1784eaf8a3
  Author: Andreas Kölbl <[email protected]>
  Date:   2016-10-29 (Sat, 29 Oct 2016)

  Changed paths:
    M hypervisor/arch/arm/Makefile
    A hypervisor/arch/arm/smp-stubs.c
    R hypervisor/arch/arm/smp.c

  Log Message:
  -----------
  arm: rename smp.c to smp-stubs.c

Add the suffix -stubs to smp.c to make it more obvious that the file
only contains stubs. Use a consistent naming for stubs (cf. cat-stubs).

Signed-off-by: Andreas Kölbl <[email protected]>
Signed-off-by: Jan Kiszka <[email protected]>


  Commit: 74f65e8e9c1928e62ae96f772212d034fb7c6c41
      
https://github.com/siemens/jailhouse/commit/74f65e8e9c1928e62ae96f772212d034fb7c6c41
  Author: Vitaly Andrianov <[email protected]>
  Date:   2016-10-29 (Sat, 29 Oct 2016)

  Changed paths:
    M inmates/lib/arm/gic-v2.c

  Log Message:
  -----------
  inmates: arm: lib: fix gic_enable() to enable SPI interrupts

The gic_enable() of gic v2 can enable only first 32 interrupts.
This commit allows to enable other interrupts as well.

Signed-off-by: Vitaly Andrianov <[email protected]>
Signed-off-by: Jan Kiszka <[email protected]>


Compare: 
https://github.com/siemens/jailhouse/compare/c54a34a292d4...74f65e8e9c19

-- 
You received this message because you are subscribed to the Google Groups 
"Jailhouse" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to [email protected].
For more options, visit https://groups.google.com/d/optout.

Reply via email to