Author: robhamerling
Date: Sat Sep 6 02:41:37 2008
New Revision: 277
Modified:
trunk/unvalidated/include/device/userguide.txt
Log:
Update for ...
Modified: trunk/unvalidated/include/device/userguide.txt
==============================================================================
--- trunk/unvalidated/include/device/userguide.txt (original)
+++ trunk/unvalidated/include/device/userguide.txt Sat Sep 6 02:41:37 2008
@@ -133,7 +133,7 @@
-- - No other includes
needed.
pragma target clock 20_000_000 -- oscillator frequency (in Hz)
- -- required by _usec_delay
+ -- required for delays
pragma target OSC HS -- high speed external oscillator
pragma target WDT Disabled -- watchdog off
@@ -142,7 +142,7 @@
enable_digital_io() -- disable analog module(s)
- var volatile bit led is pin_A1 -- define alias for pin_A1
+ var volatile bit led is pin_A1 -- define alias for pin_A1
var volatile bit led_direction is pin_A1_direction
led_direction = output -- make LED-pin output
@@ -216,8 +216,21 @@
var volatile bit INTCON_GIE at INTCON : 7
2. See the extra alias declarations for the GPIO and TRISIO
registers
and their bits. Programs and function libraries can access the
- GPIO bits with PORTx and PIN_xy names, allowing easy program
- migration from one PIC to another.
+ GPIO bits with PORTA and pin_Ay names, making it possible to
+ use libraries across a large collection of PICmicros.
+
+
+ Special Features
+ ----------------
+ The device include files contain a number of special procedures for the
+ convenience of a JAL programmer. Most procedures are in the form of a
+ pseudo variable, some are 'normal' procedures.
+ - Pseudo variables a available for TRISA, TRISB and TRISC
+ and corresponding pins for the baseline series of PICmicros.
+ This means for example that
+ pin_A2_direction = output
+ can be used even though these PIC have no TRISA register.
+
About Port Shadowing
@@ -263,22 +276,6 @@
is bad practice! Initialize an alias separatedly after the declaration.
- Special Features
- ----------------
- The device include files contain a number of special procedures for the
- convenience of a JAL programmer. Most procedures are in the form of a
- pseudo variable, some are 'normal' procedures.
- - Pseudo variables a available for TRISA, TRISB and TRISC
- and corresponding pins for the baseline.
- This means that for example that
- pin_A2_direction = output
- can be use even though these PIC have no TRISA register.
-
-
-
-
-
-
Naming convention for configuration bitmasks (fuses)
----------------------------------------------------
The configuration bits or groups of bits is such a large variety that it
@@ -319,7 +316,7 @@
EXTOSC_NOCLKOUT - External oscillator on OSC1, OSC2 is I/O
INTOSC_CLKOUT - Internal oscillator, OSC1 is I/O, ClockOut on OSC2
INTOSC_NOCLKOUT - Internal oscillator, OSC1 and OSC2 are I/O
- (some other keywords may be used)
+ (other keywords may be used as well)
Fuse_Def WDT (watchdog)
ENABLED - Watchdog enabled
@@ -365,15 +362,19 @@
ENABLED - Data Protection on, enabled
DISABLED - Data Protection off, disabled
- Notes: 1. In addition to the 'standard' fuse_defs above there may be
+ Fuse_Def IOSCFS (Internal Oscillator Frequency Select)
+ F4MHZ - 4 MHz
+ F8MHZ - 8 MHz
+
+ Notes: 1. In addition to these 'standard' fuse_defs above there may be
others, depending on the features of the specific PICmicro.
Please read the include file to see which fuse-defs are
available for your target PICmicro.
2. The terms 'Enabled' and 'Disabled' may need to be specified
where
usually 'On' and 'Off' are used.
- When the fuse_def statements cause compile-time error messages you may
- simply delete these and specify the fuse-word(s) or -byte(s) explicitly
+ When a fuse_def statement causes compile-time error messages you may
+ simply delete it and specify the fuse-word(s) or -byte(s) explicitly
with bit patterns in stead of using fuse option pragma statements.
For example for the PIC16F690 the following group of statements:
@@ -429,15 +430,15 @@
These device include files are now part of the central JalV2 repository
'Jallib' (http://jallib.googlecode.com). Other libraries of Jallib have
- been or are being converted to use the names as described in this
document.
+ been or are being converted to use the names in these device files.
You should consider to use only this combination of include files.
- Using these device include files in combination with other libraries may
- cause problems:
+ Using these device files in combination with other libraries may cause
+ problems:
- Bank switching functions are not needed with JalV2 and do not appear in
the device includes. This may cause compile-time errors when using
programs or libraries which still use these procedures. Please remove
- these bank switching functions from your programs or libraries!
+ these bank switching functions from your programs and libraries!
- The device specific include files are generated from the MPLAB .dev and
.lkr files. This may cause confusion or even conflicts because the
@@ -445,8 +446,8 @@
datasheets! Apart from that MPLAB is not errorfree, consequently include
files generated from this source are not guaranteed errorfree too!
- - The naming convention of ports and subfields is different, you may have
- to convert the other libraries.
+ - The naming convention of ports and subfields maybe different, you may
+ have to convert the other libraries.
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups
"jallib" group.
To post to this group, send email to [email protected]
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at
http://groups.google.com/group/jallib?hl=en
-~----------~----~----~----~------~----~------~--~---