Hi Richard,

I was browsing your new file and have some comments.
Most are 'informative', just to indicate places to be improved (my 
opinion!). Hope you don;t mind.


>Added: trunk/unvalidated/sample/external/lcd/Test_lcd_hd44780_tmp_4_line.jal
> ==============================================================================

....

> +pragma target OSC         HS       ;(lp,xt,hs,zie 16f887_inc_all.jal)

This refers to a non-Jallib include file!
Make sure you use and refer to Jallib files.



> +------------- PORT DEFINES -----------------------------------------------
> +
> +const bit input           = on            ; this should be in a lib
> +const bit output          = off           ; this should be in a lib
> +const byte all_input      = 0b_1111_1111  ; this should be in a lib
> +const byte all_output     = 0b_0000_0000  ; this should be in a lib

Not needed, see my previous message.


> +--b port
> +pin_b0_direction = input    ;B port
> +pin_b1_direction = input
> +pin_b2_direction = input
> +pin_b3_direction = output
> +pin_b4_direction = input
> +pin_b5_direction = input
> +pin_b6_direction = input
> +pin_b7_direction = input

Our naming convention is 'pin_B0_direction' (capital B).

And you could optimize this to:
portB_direction  = all_input
pin_B3_direction = output



> +OPTION_REG = 0B0000_0111
> +;NOT_RBPU at OPTION_REG : 7 = 0   0 = weak pull-up on port B
> +;intedg   at OPTION_REG : 6 = 0   1 = opgaande flank interupt op RB0
> +;T0CS     at OPTION_REG : 5 = 0   internal instruction cycle clock
> +;T0SE     at OPTION_REG : 4 = 0   nvt ivm setting T0CS
> +;PSA      at OPTION_REG : 3 = 0   prescaler voor timer 0
> +;PS2      at OPTION_REG : 2 = 1   prescaler op 256 (20Mhz/4/128) =
> 39062,5HZ
> +;PS1      at OPTION_REG : 1 = 1   1/(39062,5/39)TMR0 = 39>>  ~1mS = tijd
> van
> +;PS0      at OPTION_REG : 0 = 1   timer0


Many comments in Dutch!

I know it is just comments here, but PS2,PS1,PS0 don't exist in Jallib 
device files. You can specify the T0 prescaler as:
   OPTION_REG_PS = 7



Regards, Rob.



-- 
Rob Hamerling, Vianen, NL (http://www.robh.nl/)



--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"jallib" group.
To post to this group, send email to [email protected]
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at 
http://groups.google.com/group/jallib?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to