Hi Eur,
> 1) it says how the files should NOT be named. This is not good. > Yes, JSG specifies that anything but tests must not start with "test_". This is called a reserved prefix :) > How should the sample files be named? > Use your imagination, we're all human after all ! I personally don't want to put too much "guidelines" for samples. Samples should be named so filenames have a meaning, describe at least a little bit of what the content is about. test1.jal is bad. serial_hw_echo.jal is good (I'm not saying that because I did name it:)). It's left to the developer. About sht and tc77 samples, what do they do ? Do they "read", or do they "start" ? Board files are named as board_<pic>_<whatever>.jal > > Explain what a board file is, so I know it too. > There are lots of posts talking about these board files. One of the last is this one (but you should first search the group the load the history) http://groups.google.com/group/jallib/browse_frm/thread/a84aab2fe08b326d/16072c52790e7a2e?lnk=gst&q=board#16072c52790e7a2e I still don't like the "whatever" parts and the dual ways of naming libs. > The <whatever> is left to the developer's imagination, and is a way for him to express his thoughts, and put his signature on the libs, as a clean, clear, simple API. Don't you think ? The dual ways of naming libs is because there are two way of designing a lib. Cheers, Seb, -- Sébastien LELONG http://www.sirloon.net http://sirbot.org --~--~---------~--~----~------------~-------~--~----~ You received this message because you are subscribed to the Google Groups "jallib" group. To post to this group, send email to [email protected] To unsubscribe from this group, send email to [EMAIL PROTECTED] For more options, visit this group at http://groups.google.com/group/jallib?hl=en -~----------~----~----~----~------~----~------~--~---
