On Wed, Aug 19, 2009 at 1:29 PM, Joep Suijs <[email protected]> wrote:
> Fat32 with only 50 bytes of RAM. Impressive! > I think matt meant 50 bytes to spare... Sunish > > I would suggest you create one (or maybe two) library files and > control the functionality with constants before the include. > Within the library file, you could optionally include other files, eg > the file that does non-defragmented files (to replace the 'simple' > read. > > There are a few advantages for this aproach: > - There is only one include for the user to remember. > - You don't duplicate code (or only to a very limited level). > > How do you get files on you disk with your first library? If you can > answer that, I think it is usefull to release it. > It would be very usefull if you could read, write and delete a file - > even if write means you have to specify it's max size in advance or > so. > > > > 2009/8/19 mattschinkel <[email protected]>: > > > > Some of you may know that I am working on fat32 libs. > > This current version will fit on 16F877 with 50 ram to spare and also > > works on 18F452. > > > > I have a working version that is able to do the following: > > -list files a directory > > -go to a directory > > -go to a file > > -read a file (file must be defragmented) > > > > In the future, there are lots more functions that can be added, such > > as: > > -create a file > > -write to a file > > -create a directory > > -read a file that is not defragmented > > > > > > Should there be different lib versions with different pic memory > > requirements? > > > > The difference between reading a defragmented file and a fragmented > > file is great. fragmented files will take more memory space and > > processing time. > > > > Should I release a 16F877 version with 50 bytes ram left on the chip? > > Many people do have 16F877 in there tool box, they may want to try it > > out before they upgrade there pic. > > > > If I do make different versions, how should I name the libs? eg. > > fat32_v1.jal, fat32_v2.jal, etc. > > > > > > > > > --~--~---------~--~----~------------~-------~--~----~ You received this message because you are subscribed to the Google Groups "jallib" group. To post to this group, send email to [email protected] To unsubscribe from this group, send email to [email protected] For more options, visit this group at http://groups.google.com/group/jallib?hl=en -~----------~----~----~----~------~----~------~--~---
