Hi Seb,

Sebastien Lelong wrote:

>     This will have its effect on compilability of samples and other existing
>     programs, especially those who contain
>     more_than_100_characters_long_and_not_easy_to_remember keywords!
>     The lucky ones are those who work with a bootloader and don't have to
>     specify fuse settings.
> 
> 
> Does this mean we'll have a lot this_is_a_fuse_setting stuff instead of 
> short ones ?

No, the other way around! Short keywords will replace the long 
'descriptive_sentences', for example the fuse_Def WPEND of 18F24j11:

> pragma fuse_def WPEND:6 0x40 {
>        PAGES_WPFP_5_0_TO_CONFIGURATION_WORDS_PAGE_WRITE_ERASE_PROTECTED = 0x40
>        PAGE_0_TO_WPFP_5_0_ERASE_WRITE_PROTECTED = 0x0

will be replaced by something like:

> pragma fuse_def WPEND:6 0x40 {
>        PWPFP_END = 0x40
>        P0_WPFP = 0x0


Another one for the 18f46j50:

> pragma fuse_def WPFP:6 0x3F {
>        WRITE_PROTECT_PROGRAM_FLASH_PAGE_0 = 0x0
>        WRITE_PROTECT_PROGRAM_FLASH_PAGE_1 = 0x1
>        WRITE_PROTECT_PROGRAM_FLASH_PAGE_2 = 0x2
>        WRITE_PROTECT_PROGRAM_FLASH_PAGE_3 = 0x3
etc to
>        WRITE_PROTECT_PROGRAM_FLASH_PAGE_63 = 0x3F
>  }

will become something like:

 > pragma fuse_def WPFP:6 0x3F {
 >        P0 = 0x0
 >        P1 = 0x1
 >        P2 = 0x2
 >        P3 = 0x3
etc to
 >        P63 = 0x3F
 >  }

Much more convenient, isn't it?

 > Something like enable_watchdog_feature instead of just WDT?

As I said: the other way around! WDT and all the other short keywords we 
currently have will not change. Just for the 'exotic' long ones I want 
to find a shorter keyword.
Maybe I'll have a look in the MPASM .inc files or MCC18 header files for 
inspiration.

> That wouldn't be good news and would have big impact on readability, 
> which is what I'm worried about...

Don't worry, be happy!
Only the current sample programs which have complete fuse_def 
specifications will be involved, and these are mostly generated from a 
single board file.

> Can you give some examples ? Could aliases be created for the most 
> common ones ?

Aliases won't be needed after I've made some progress. And I don't know 
if aliases work for pragmas like fuse_def!

Regards, Rob.

-- 
Rob Hamerling, Vianen, NL (http://www.robh.nl/)

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"jallib" group.
To post to this group, send email to [email protected]
To unsubscribe from this group, send email to 
[email protected]
For more options, visit this group at 
http://groups.google.com/group/jallib?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to