Hi guys, We have a nice delay library, but many examples use the internal _usec_delay() procedure. I can imagine the generated blink examples do so to remove as much complexity (dependancy) out as possible. But I don't understand why the library is not used with other samples. First of all, the underscore indicates it is intended for internal use, so it is bad habit to use it in samples since it educates people to use it. Secondly, each use of _usec_delay() generates it own loop for the requested delay so frequent use of it in large programs makes the target code larger then required. And last but not least, delays in samples are generally over 1ms (and often over 100ms) and express those in microseconds does not make your program more readable. Or don't you agree delay_1ms(500) or delay_100ms(5) easier to read then _usec_delay(500000) ?
So I suggest that we don't use _use_delay() like all other procedures starting with an underscore in samples, unless there is a good reaseon for. What do you think? Joep -- You received this message because you are subscribed to the Google Groups "jallib" group. To post to this group, send email to [email protected]. To unsubscribe from this group, send email to [email protected]. For more options, visit this group at http://groups.google.com/group/jallib?hl=en.
