Comment #2 on issue 150 by sebastien.lelong: GLCD refactoring
http://code.google.com/p/jallib/issues/detail?id=150
There are two main ways to use GLCD:
- char-based stuff
- pixel-based stuff
I suggest every char-based proc/func go to glcd_font.jal. All pixel-based
proc/func could remain in glcd_common.jal (maybe renamed).
Ex: lcd_set_cursor(row,col) is char-based, because args correspond to
row/col in a grid defined by font width * height. It's not named
appropriately. And maybe it could go to glcd_font.jal
Ex2: in nokia 3310 lib, there's a lcd_gotoxy(x,y). This time pixel based.
Maybe this procedure could be part of standard API, meaning every GLCD lib
should implement it.
--
You received this message because you are subscribed to the Google Groups
"jallib" group.
To post to this group, send email to [email protected].
To unsubscribe from this group, send email to
[email protected].
For more options, visit this group at
http://groups.google.com/group/jallib?hl=en.