Hi again Kausik.

Thanks for sending the images - these helped clarify whats going on.
I'll just take each of your steps in turn...

On 17/10/2016 16:31, Kausik Datta wrote:
> Sadly, still no joy. My machine is a Core i7 with 16GB RAM, and yet, 
> modifying the max-heap to 2048M didn't work for the jalview.jnlp file (I 
> tried up to 4096M; I even tried increasing the initial heap to 500M). I 
> downloaded the 2GB launchApp.jnlp from your website. Upon double-clicking it, 
> I got the usual Java prompts and then it failed to start. 
It's very easy to make a mistake in the JNLP file. Failure to start
(with an error message hidden away somewhere in the console) is the
usual symptom.

> I put in http://www.jalview.org in my Java security exception list, but that 
> didn't help. 
You should not need to do this. We use a fully trusted certificate to
sign Jalview when launched from www.jalview.org.

Just to be sure, I recommend you remove any exceptions concerning
www.jalview.org before continuing. These might affect the security check.

> In my Process Manager, I see that upon opening the launchApp.jnlp, the Java 
> jp2launcher.exe starts up (screenshot), and then shuts down on its own. 
> Opening the jalview.jnlp starts javaws.exe, which also shuts down on its own. 
> I have attached the two .jnlp files I tried to use.

The shutdown suggests that there was an error in the jnlp file
downloaded. Taking a look at your launchApp.jnlp file, nothing appears
to be wrong, but we have seen some odd behaviour in the past with this,
so rather than debug the files you sent, I'd like you to try the following:

1. First - enable the Java webstart console (under the 'Advanced' tab of
your Java preferences)

2. Open the 'Command Prompt' app (you should be able to just hit the
launcher menu and type 'Command' ..)..

3. Type the following - exactly as shown:
javaws "http://www.jalview.org/services/launchApp?jvm-max-heap=7G";

On hitting return, you should see a Java webstart dialog open and the
Jalview desktop start to download and launch Jalview. Check your memory
settings by enabling Tools->Show Memory Usage.

If this doesn't work, try changing '7' to '3', and repeat.

Lastly, if things still dont work, if the Java web start console is
displayed, please copy and paste any messages into a file and send them
to me. If you also get an 'Application failed to launch' dialog then
also send me the 'Wrapped exception' output.. which gives the reason why
the webstart launch failed.


Dr JB Procter, Jalview Coordinator, The Barton Group
Division of Computational Biology, School of Life Sciences
University of Dundee, Dundee DD1 5EH, UK.
+44 1382 388734 | www.jalview.org | www.compbio.dundee.ac.uk

Jalview-discuss mailing list

Reply via email to