[ 
https://issues.apache.org/jira/browse/LUCENE-2140?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12789751#action_12789751
 ] 

Uwe Schindler commented on LUCENE-2140:
---------------------------------------

Maybe the method should have a better name instead of minXXXX: This is not the 
minimum possible boost, that would go into the PQ, it is the largest boost that 
would not go into the PQ (so the check in the enum should be: accept term only 
if its boost is > boost hint).

> TopTermsScoringBooleanQueryRewrite minscore
> -------------------------------------------
>
>                 Key: LUCENE-2140
>                 URL: https://issues.apache.org/jira/browse/LUCENE-2140
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: Search
>    Affects Versions: Flex Branch
>            Reporter: Robert Muir
>            Assignee: Uwe Schindler
>            Priority: Minor
>             Fix For: Flex Branch
>
>         Attachments: LUCENE-2140.patch
>
>
> when using the TopTermsScoringBooleanQueryRewrite (LUCENE-2123), it would be 
> nice if MultiTermQuery could set an attribute specifying the minimum required 
> score once the Priority Queue is filled. 
> This way, FilteredTermsEnums could adjust their behavior accordingly based on 
> the minimal score needed to actually be a useful term (i.e. not just pass 
> thru the pq)
> An example is FuzzyTermsEnum: at some point the bottom of the priority queue 
> contains words with edit distance of 1 and enumerating any further terms is 
> simply a waste of time.
> This is because terms are compared by score, then termtext. So in this case 
> FuzzyTermsEnum could simply seek to the exact match, then end.
> This behavior could be also generalized for all n, for a different impl of 
> fuzzyquery where it is only looking in the term dictionary for words within 
> edit distance of n' which is the lowest scoring term in the pq (they adjust 
> their behavior during enumeration of the terms depending upon this attribute).
> Other FilteredTermsEnums could make use of this minimal score in their own 
> way, to drive the most efficient behavior so that they do not waste time 
> enumerating useless terms.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscr...@lucene.apache.org
For additional commands, e-mail: java-dev-h...@lucene.apache.org

Reply via email to