The following small set of changes are needed after merging the latest changes in the main repository.
The conflicting changeset was that for this issue:
JDK-8196027: Remove "Prev" and "Next" links from the javadoc navigation
https://bugs.openjdk.java.net/browse/JDK-8196027

   $ hg diff
   test/langtools/jdk/javadoc/doclet/testNavigation/TestModuleNavigation.java
   diff -r ba19a21d727d
   test/langtools/jdk/javadoc/doclet/testNavigation/TestModuleNavigation.java
   ---
   a/test/langtools/jdk/javadoc/doclet/testNavigation/TestModuleNavigation.java
   Wed Feb 07 09:48:43 2018 -0800
   +++
   b/test/langtools/jdk/javadoc/doclet/testNavigation/TestModuleNavigation.java
   Wed Feb 07 11:15:59 2018 -0800
   @@ -82,23 +82,23 @@
                     "Prev",
                     "Next");

   -        checkOutput("m-summary.html", false,
   +        checkOutput("m/module-summary.html", false,
                     "Prev Module",
                     "Next Module");

   -        checkOutput("m2p1/package-summary.html", false,
   +        checkOutput("m2/m2p1/package-summary.html", false,
                     "Prev Package",
                     "Next Package");

   -        checkOutput("m2p1/Am2.html", false,
   +        checkOutput("m2/m2p1/Am2.html", false,
                     "Prev Class",
                     "Next Class");

   -        checkOutput("m2p1/class-use/Am2.html", false,
   +        checkOutput("m2/m2p1/class-use/Am2.html", false,
                     "Prev",
                     "Next");

   -        checkOutput("m2p1/package-tree.html", false,
   +        checkOutput("m2/m2p1/package-tree.html", false,
                     "Prev",
                     "Next");


-- Jon

On 02/07/2018 09:58 AM, Jonathan Gibbons wrote:
Thanks. I'll look at tweaking the style of the lines you mention.

-- Jon

On 02/07/2018 08:59 AM, Kumar Srinivasan wrote:

Hi Jon,

Looks good to me, minor nits....

DocPaths.java

long line: might exceed 100 chars

+ return (typeElement == null) ? DocPath.empty : forPackage(utils.containingPackage(typeElement));


suggest

+        return (typeElement == null)
+             ? DocPath.empty
+             : forPackage(utils.containingPackage(typeElement));

TestFrames.java

I am uncertain of readability of breaking up the ternary operator here, since it is
a lambda expression, I will leave it you.

+ .map(c -> (isInModule(c) ? (modulePart(c) + "/") : "") + packagePart(c) + "/package-frame.html")

and

+ .map(c -> (isInModule(c) ? (modulePart(c) + "/") : "") + toHtml(packageClassPart(c)))



Otherwise looks good,I don't need to see anotheriteration, if the changes are limited to style fix-ups.

Thanks
Kumar


Please review changes, including a couple of small build changes, to reorganize the generated
documentation into per-module directories.

Build folk: the changes are just to move the generated module graph images into the new hierarchy.

Javadoc folk: the changes are mostly simple, with most of the "magic" happening in the DocPaths factory class, creating old-style or new-style paths as appropriate. Care is taken in DocFilesHandlerImpl, where DocPath objects are used for input, and have to work in conjunction with the module Locations. Other than than, some factory methods moved from DocPath to DocPaths, and most factory methods were changed from static to instance methods, to be able to take the interim backwards-compatibility option into account.

This work leverages JDK-8195796, to reduce the size of relative URLs in generated docs.

JBS: https://bugs.openjdk.java.net/browse/JDK-8195795
CSR: https://bugs.openjdk.java.net/browse/JDK-8196112
Webrev: http://cr.openjdk.java.net/~jjg/8195795/webrev.00/

-- Jon



Reply via email to