On Mon, 20 Nov 2023 13:50:45 GMT, Alan Bateman <[email protected]> wrote:
> [...] it does make the java launcher code much simpler. Yes. That's a very nice effect of surfacing the launch protocol directyl in `java.lang.Class` > So I'm not sure about the naming, it feels more like a `findMainMethod` to > emphasize the search or just `mainMethod`. +1 for `findMainMethod`, and also an explicit `Optional<Method>` as the return type. ------------- PR Review Comment: https://git.openjdk.org/jdk/pull/16461#discussion_r1399240835
