On Tue, 18 Feb 2025 16:10:01 GMT, Chen Liang <[email protected]> wrote:
>> src/jdk.javadoc/share/classes/jdk/javadoc/internal/doclets/formats/html/taglets/SnippetTaglet.java
>> line 140:
>>
>>> 138: } else {
>>> 139: Element e = null;
>>> 140: String linkEncountered = null;
>>
>> Since the primary purpose of this variable is now to carry the link target
>> (and checking for overlapping links is just a side-use) I would prefer
>> something like `linkTarget` as name.
>
> Hmm, I thought this means "the link you have encountered" and didn't raise a
> point during review.
I thought of this as referring to link we've encountered, but I can change the
name for clarity
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/23328#discussion_r1960193268