Title: Message

 
 I am using JBoss 3.2.1 with JDK 1.4.2 and i get the following error:

javax.jms.JMSSecurityException: User: null is NOT authenticated
at org.jboss.mq.security.SecurityManager.authenticate(SecurityManager.java:215)
at org.jboss.mq.security.ServerSecurityInterceptor.authenticate(ServerSecurityInterceptor.java:51)
at org.jboss.mq.server.TracingInterceptor.authenticate(TracingInterceptor.java:650)
at org.jboss.mq.server.JMSServerInvoker.authenticate(JMSServerInvoker.java:288)
at org.jboss.mq.il.jvm.JVMServerIL.authenticate(JVMServerIL.java:302)
at org.jboss.mq.Connection.authenticate(Connection.java:876)
at org.jboss.mq.Connection.<init>(Connection.java:238)
at org.jboss.mq.Connection.<init>(Connection.java:315)
at org.jboss.mq.SpyConnection.<init>(SpyConnection.java:60)
at org.jboss.mq.SpyConnectionFactory.createTopicConnection(SpyConnectionFactory.java:78)
at ...

I can't predict when the problem appears, but when it appears a server restart is required for the jms topic to function correctly.

My config file is:
<?xml version="1.0" encoding="UTF-8"?>
<server>
<mbean code="org.jboss.mq.il.jvm.JVMServerILService"
name="jboss.mq:service=ReactorInvocationLayer,type=JVM">
<depends optional-attribute-name="Invoker">jboss.mq:service=Invoker</depends>
<attribute name="ConnectionFactoryJNDIRef">TopicConnectionFactory</attribute>
<attribute name="XAConnectionFactoryJNDIRef">XATopicConnectionFactory</attribute>
<attribute name="PingPeriod">0</attribute>
</mbean>

<mbean code="org.jboss.mq.server.jmx.Topic"
name="jboss.mq.destination:service=Topic,name=PolicyExecution">
<depends optional-attribute-name="DestinationManager">jboss.mq:service=DestinationManager</depends>
</mbean>

</server>

Does anyone knows what is going on?

Reply via email to