Thanks for the answers Jesse!

> Try specifically: mvn clean hpi:run

Same issue. Builds fine no obvious errors in the terminal output and 
Jenkins starts normally. Plugin is listed in the list of installed plugins 
but I cannot use it in a Pipeline or Freestyle job.

> Why? This would be extremely unusual.

I'm using Dagger 2 for dependency injection because 1) I'm used to using it 
in other Java projects 2) whilst I've been developing the plugin in the IDE 
it just worked 3) I am not aware of any banned / incompatible Java 
libraries that we must not use (but obviously I am happy to be corrected on 
this).

Any further tips on attempting to track down the cause of this?

On Wednesday, 11 September 2019 14:38:04 UTC+1, Jesse Glick wrote:
>
> On Wed, Sep 11, 2019 at 3:20 AM Mez Pahlan <mez....@gmail.com 
> <javascript:>> wrote: 
> > I've looked at the local work directory in my IDE that is created when 
> hpi:run is executed and I can see a file called appcenter.hpl but there 
> isn't an expanded folder called appcenter in the way that other plugins 
> have expanded folders. 
>
> This is normal. The link file points to source directories rather than 
> needing an archive to be unpacked. 
>
> > I have also tried running the mvn hpi:run command from outside of the 
> IDE and I get the same issue. 
>
> Try specifically 
>
> mvn clean hpi:run 
>
> > I've added an annotation processor in my POM 
>
> Why? This would be extremely unusual. 
>

-- 
You received this message because you are subscribed to the Google Groups 
"Jenkins Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to jenkinsci-dev+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/jenkinsci-dev/c413ae0c-d0eb-4d56-8698-f6eae88664a8%40googlegroups.com.

Reply via email to