Hi Voll AufMühlen,

I have been trying to configure Jenkins to launch Windows EC2 instances.
I have had success only with linux instances. 

With windows instances I have been unsuccessful. My Jenkins is able to 
launch the windows instance, but post that, nothing happens. The windows 
is launched(as I can see on my AWS console). But the slave node(this 
windows ec2 node) never comes online.

Also, a few weeks ago I tried this activity, when I received the error with 
WinRM; the node was lunched but jenkins was not able to connect to this 

Since you have been able to connect your windows ec2 instance with your 
Jenkins; can you please help me configure the same.

Which plugin do you use in Jenkins for connecting to AWS cloud?
Settings you have done in (Jenkins configure) cloud option.
Settings needed on AWS?
How do you manage the authentication(User name and password for your 
windows EC2 slaves.0

It will be really helpful if you can help me with the same.

Thanks and regards,
Vinay Sharma


On Tuesday, 8 March 2016 19:56:56 UTC+5:30, Voll AufMühlen wrote:
> Hi there,
> hope that you can help me out :)
> my Configuration :* Jenkins Master, Version: 1.651 (Ubuntu 14.04 LTS 
> 64bit)*
>     *Launching via: JNLP*
> *    Java Version: 1.80_65    Windows Slave Plugin: 1.1*
> it's 3 days now that i have searched the whole internet, but couldn't find 
> an answer to my problem.
> The Problem. I have several Linux slaves that are connecting with jenkins 
> master without a problem. And I have one Windows 2012 RS slave that is 
> working without problems. But when I try to add a new windows slave (again 
> Windows 2012 R2), (with JNLP) I always receive an error.
> I tried everything. Using the jenkins URL ....using Jenkins IP 
> instead....shutting down the firewall on windows slave. There is no proxy 
> on the network.
> My thoughts are.....*The Jenkins Master is trying to connect with every 
> Windows Jenkins Slave using the same port and that is the problem her*e.
> --------------------------------------------------------------------------
> C:\Windows\system32>"C:\Program Files\Java\jre1.8.0_65\bin\java.exe" -jar 
> C:\jenkins\slave.jar -jnlpUrl  
> https://jenkins.de/computer/JSlave/slave-agent.jnlp -secret 
> hudson.remoting.jnlp.Main createEngine
> INFO: Setting up slave:
> hudson.remoting.jnlp.Main$CuiListener <init>
> INFO: Jenkins agent is running in headless mode.
> hudson.remoting.jnlp.Main$CuiListener status
> INFO: Locating server among [https://jenkins.de/]
> hudson.remoting.jnlp.Main$CuiListener status
> INFO: Handshaking
> hudson.remoting.jnlp.Main$CuiListener status
> INFO: Connecting to jenkins.de:58844 (retrying:2)
> java.net.ConnectException: Connection timed out: connect
>         at java.net.DualStackPlainSocketImpl.connect0(Native Method)
>         at java.net.DualStackPlainSocketImpl.socketConnect(Unknown Source)
>         at java.net.AbstractPlainSocketImpl.doConnect(Unknown Source)
>         at java.net.AbstractPlainSocketImpl.connectToAddress(Unknown 
> Source)
>         at java.net.AbstractPlainSocketImpl.connect(Unknown Source)
>         at java.net.PlainSocketImpl.connect(Unknown Source)
>         at java.net.SocksSocketImpl.connect(Unknown Source)
>         at java.net.Socket.connect(Unknown Source)
>         at java.net.Socket.connect(Unknown Source)
>         at java.net.Socket.<init>(Unknown Source)
>         at java.net.Socket.<init>(Unknown Source)
>         at hudson.remoting.Engine.connect(Engine.java:327)
>         at hudson.remoting.Engine.run(Engine.java:235)
> ---------------------------------------------------------------------------------------------------------------
> And here is the log outpout on the Jenkins Master:
> /var/lib/jenkins/logs/slaves/JSlave/slave.log
> Verbinde zu JSlave
> ERROR: Unerwarteter Fehler beim Starten eines Slave-Prozesses aufgetreten. 
> Vermutlich handelt es sich um einen Fehler in Jenkins.
> JSlave: unknown error
>         at java.net.Inet6AddressImpl.lookupAllHostAddr(Native Method)
>         at java.net.InetAddress$2.lookupAllHostAddr(InetAddress.java:928)
>         at 
> java.net.InetAddress.getAddressesFromNameService(InetAddress.java:1323)
>         at java.net.InetAddress.getAllByName0(InetAddress.java:1276)
>         at java.net.InetAddress.getAllByName(InetAddress.java:1192)
>         at java.net.InetAddress.getAllByName(InetAddress.java:1126)
>         at java.net.InetAddress.getByName(InetAddress.java:1076)
>         at 
> hudson.os.windows.ManagedWindowsServiceLauncher.launch(ManagedWindowsServiceLauncher.java:190)
>         at hudson.slaves.SlaveComputer$1.call(SlaveComputer.java:253)
>         at 
> jenkins.util.ContextResettingExecutorService$2.call(ContextResettingExecutorService.java:46)
>         at java.util.concurrent.FutureTask.run(FutureTask.java:266)
>         at 
> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
>         at 
> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
>         at java.lang.Thread.run(Thread.java:745)
> ---------------------------------------------------------------------------------------------------------------
> Can someone tell me where the problem is?

You received this message because you are subscribed to the Google Groups 
"Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to jenkinsci-users+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
For more options, visit https://groups.google.com/d/optout.

Reply via email to