On Thursday, April 19, 2012 at 5:13:30 PM UTC+5:30, Lee Winder wrote:
> I have a single batch file which calls a number of executables which 
> builds various assets for our application.  When I run the batch file 
> manually it works perfectly (the command prompt opens, the assets are built 
> - takes about 10 minutes - and then it closes).
> If I run this batch file via a build step, it successfully calls the batch 
> file, but the individual steps inside the batch file fail (it just skips 
> over each one).  I'm assuming this is down to some permission issue between 
> the user used when I run the file manually and the user used when Jenkins 
> runs it.
> If I move the content of the batch file into the build step itself I get 
> the same results.
> In the System Information screen my user name is actually my computer name 
> (with a $ on the end) rather than an explicit user as defined in my system 
> admin.
> What user is used to run build steps and how can I change that user?  Has 
> anyone else experienced this problem before and has a solution?
> Thanks
> Lee

Hi all,
I too faced same kind of issue. Using Jenkins, i trying to do deploy the 
war artifact in tomcat manually. To do that, instead of using plugin, wrote 
script in "windows batch command " but i getting below error.

BUILD SUCCESSFULTotal time: 5 seconds
[Ant-tomcat] $ cmd /c call C:\WINDOWS\TEMP\hudson4425405522418561213.bat

C:\Program Files (x86)\Jenkins\workspace\Ant-tomcat>echo "Starting to copy the 
"Starting to copy the build"

C:\Program Files (x86)\Jenkins\workspace\Ant-tomcat>copy C:\Program Files 
The system cannot find the file specified.

C:\Program Files (x86)\Jenkins\workspace\Ant-tomcat>echo "Copied the build to 
"Copied the build to tomcat"

C:\Program Files (x86)\Jenkins\workspace\Ant-tomcat>exit 1 
Build step 'Execute Windows batch command' marked build as failure
Finished: FAILURE

Kindly help me to solve this issue.

then i tried the same manually in command prompt using copy command but no use.

D:\>copy C:\Program Files 
The system cannot find the file specified.

anyone has a solution for this?

You received this message because you are subscribed to the Google Groups 
"Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to jenkinsci-users+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
For more options, visit https://groups.google.com/d/optout.

Reply via email to