I also uninstalled or downgraded all the others in that list of plugins 
except for workflow-cps (no option to do either for that) and restarted and 
still no good.

On Thursday, February 13, 2020 at 3:47:12 PM UTC-8, Glenn Caccia wrote:
>
> I have a Jenkins project that runs a maven build.  The maven build 
> includes a step where it uses axistools, maven goal wsdl2java, to build 
> classes from a soap service endpoint. This has been working fine for the 
> past few years. The last good build was from 1/31. On 2/4 I tried to build 
> this same project and suddenly that step was failing. I noticed that the 
> step is now including new parameters that were not present before. In the 
> last good build, I see a step like this.. [DEBUG] argslist: [-o, 
> /var/lib/jenkins/jobs/xxx/workspace/target/generated-sources/java, -w, -T, 
> 1.1, 
> file:/var/lib/jenkins/jobs/xxx/workspace/target/axistools/wsdl2java/urlDownloads/http---xxx.xxx.com-8080-xxx-wsdl.wsdl]
>  
> But now, with the builds that are failing, I see this... [DEBUG] 
> argslist: [-o, 
> /var/lib/jenkins/jobs/xxx/workspace/target/generated-sources/java, -w, -T, 
> 1.1, -U, , -P, , 
> file:/var/lib/jenkins/jobs/xxx/workspace/target/axistools/wsdl2java/urlDownloads/http---xxx.xxx.com-8080-xxx-wsdl.wsdl]
>  So 
> something is injecting -U, , -P, ,. I looked at what plugins had been 
> recently updated and found the following... 
> config-file-provider
> github-branch-source
> script-security
> workflow-cps
> subversion
> The script-security plugin seemed like a likely suspect and I downgraded 
> it and restarted Jenkins, but still get same issue. Config-file-provider 
> does not provide a downgrade option. Any thoughts? 
>

-- 
You received this message because you are subscribed to the Google Groups 
"Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to jenkinsci-users+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/jenkinsci-users/30f369cf-2a77-455c-ab26-375ff9725db1%40googlegroups.com.

Reply via email to