I think that to set the javaName to the old name is enough, but you should do this for all table.
But I am not sure of this, I a newbie as well, just trying to figure out :) Pierre > -----Original Message----- > From: Martin Kisimov [mailto:MartinK@;discovery.co.za] > Sent: vendredi, 15. novembre 2002 14:30 > To: 'Jetspeed Users List' > Subject: RE: extending jetspeed security model > > > *********************** > Your mail has been scanned by InterScan. > ***********-*********** > > > Pierre, > > We have changed the names for all the tables, apart from the > user table. Are > there any other constants we need to change in order for the generated > classes to conform > > > -----Original Message----- > From: Pierre Henry [mailto:phenry@;proconcept.ch] > Sent: 15 November 2002 03:04 > To: Jetspeed Users List > Subject: RE: extending jetspeed security model > > > Martin, here are the steps I already went through : > > > 1. Modify the torque schema.xml : > > I changed the name of the table user to MYUSER, but I specified > JavaName=TurbineUser, so that the generated classes keep the > same name. > Added the 'title' field. > <table name="MYUSER" idMethod="idbroker" javaName="TurbineUser"> > ... > <column name="TITLE" size="99" type="VARCHAR" /> > ... > </table> > > I rebuilt to generate the peer classes. > > > 2. Create a MyUser interface and a MyUserImpl class > > MyUser extends JetspeedUser and add the setTitle and getTitle > methods, and > the static final String TITLE = "title". > > MyUserImpl extends BaseJetspeedUser and implements MyUser : > > public class MyUserImpl extends BaseJetspeedUser implements MyUser { > public String getTitle(){ > return (String) getPerm(MyUser.TITLE); > } > public void setTitle(String title){ > setPerm(PcsUser.TITLE, title); > } > } > > > 3. Modifiy the JetspeedSecurity.* files > > set > "services.JetspeedSecurity.user.class=myclasses.portal.om.secu > rity.MyUserImp > l" > > Wherever this parameter appears. > > > > I hope this can help you, and I hope this is the right way to do it :) > > cheers > > Pierre > > > -- > To unsubscribe, e-mail: <mailto:jetspeed-user-unsubscribe@;jakarta.apache.org> For additional commands, e-mail: <mailto:jetspeed-user-help@;jakarta.apache.org>
