On 16/05/2017 09:50, Peter Levart wrote:
:
If I remember correctly, there was a phase in jigsaw development when
there was a class named ModuleClassLoader.
There was although it was replaced in 2015.
:
Above two utility methods (defineModulesWithOneLoader and
defineModulesWithManyLoaders) could then be just special cases:
defineModulesWithLoaderPerSubset(..., mn -> true); // equivalent to
defineModulesWithOneLoader(...)
defineModulesWithLoaderPerSubset(..., mn -> mn); // equivalent to
defineModulesWithManyLoaders(...)
What do you think?
My personal view is that we should keep the complexity out of the API.
If super advanced users want to use their own class loaders to load
modules then they can do so with the defineModules. Yes, this does mean
that anyone doing this needs to know how to translate readability and
exports into delegation but it's a small/advanced group I think.
-Alan