[ 
https://issues.apache.org/jira/browse/KAFKA-6238?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16362659#comment-16362659
 ] 

Ivan Babrou commented on KAFKA-6238:
------------------------------------

We're upgrading from 0.11.0 and still see:

{noformat}
Feb 13 16:46:15 myhost kafka[16170]: java.lang.IllegalArgumentException: 
requirement failed: log.message.format.version 1.0-IV0 cannot be used when 
inter.broker.protocol.version is set to 0.11.0
Feb 13 16:46:15 myhost kafka[16170]:         at 
scala.Predef$.require(Predef.scala:277)
Feb 13 16:46:15 myhost kafka[16170]:         at 
kafka.server.KafkaConfig.validateValues(KafkaConfig.scala:1206)
Feb 13 16:46:15 myhost kafka[16170]:         at 
kafka.server.KafkaConfig.<init>(KafkaConfig.scala:1170)
Feb 13 16:46:15 myhost kafka[16170]:         at 
kafka.server.KafkaConfig$.fromProps(KafkaConfig.scala:881)
Feb 13 16:46:15 myhost kafka[16170]:         at 
kafka.server.KafkaConfig$.fromProps(KafkaConfig.scala:878)
Feb 13 16:46:15 myhost kafka[16170]:         at 
kafka.server.KafkaServerStartable$.fromProps(KafkaServerStartable.scala:28)
Feb 13 16:46:15 myhost kafka[16170]:         at 
kafka.Kafka$.main(Kafka.scala:82)
Feb 13 16:46:15 myhost kafka[16170]:         at kafka.Kafka.main(Kafka.scala)
{noformat}

This is with only inter.broker.protocol.version=0.11.0. Docs say:

{quote}
If you are upgrading from 0.11.0.x and you have not overridden the message 
format, then you only need to override the inter-broker protocol format.
* inter.broker.protocol.version=CURRENT_KAFKA_VERSION (e.g. 0.8.2, 0.9.0, 
0.10.0, 0.10.1, 0.10.2, 0.11.0).
{quote}
 

> Issues with protocol version when applying a rolling upgrade to 1.0.0
> ---------------------------------------------------------------------
>
>                 Key: KAFKA-6238
>                 URL: https://issues.apache.org/jira/browse/KAFKA-6238
>             Project: Kafka
>          Issue Type: Bug
>          Components: documentation
>    Affects Versions: 1.0.0
>            Reporter: Diego Louzán
>            Assignee: Jason Gustafson
>            Priority: Major
>             Fix For: 1.0.1
>
>
> Hello,
> I am trying to perform a rolling upgrade from 0.10.0.1 to 1.0.0, and 
> according to the instructions in the documentation, I should only have to 
> upgrade the "inter.broker.protocol.version" parameter in the first step. But 
> after setting the value to "0.10.0" or "0.10.0.1" (tried both), the broker 
> refuses to start with the following error:
> {code}
> [2017-11-20 08:28:46,620] FATAL  (kafka.Kafka$)
> java.lang.IllegalArgumentException: requirement failed: 
> log.message.format.version 1.0-IV0 cannot be used when 
> inter.broker.protocol.version is set to 0.10.0.1
>         at scala.Predef$.require(Predef.scala:224)
>         at kafka.server.KafkaConfig.validateValues(KafkaConfig.scala:1205)
>         at kafka.server.KafkaConfig.<init>(KafkaConfig.scala:1170)
>         at kafka.server.KafkaConfig$.fromProps(KafkaConfig.scala:881)
>         at kafka.server.KafkaConfig$.fromProps(KafkaConfig.scala:878)
>         at 
> kafka.server.KafkaServerStartable$.fromProps(KafkaServerStartable.scala:28)
>         at kafka.Kafka$.main(Kafka.scala:82)
>         at kafka.Kafka.main(Kafka.scala)
> {code}
> I checked the instructions for rolling upgrades to previous versions (namely 
> 0.11.0.0), and in here it's stated that is also needed to upgrade the 
> "log.message.format.version" parameter in two stages. I have tried that and 
> the upgrade worked. It seems it still applies to version 1.0.0, so I'm not 
> sure if this is wrong documentation, or an actual issue with kafka since it 
> should work as stated in the docs.
> Regards,
> Diego Louzán



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to