Andrew Schofield created KAFKA-19653: ----------------------------------------
Summary: Improve metavariable names for verifiable producer/consumer Key: KAFKA-19653 URL: https://issues.apache.org/jira/browse/KAFKA-19653 Project: Kafka Issue Type: Sub-task Reporter: Andrew Schofield Assignee: Andrew Schofield The metavariable names in the usage messages for the verifiable producer, consumer and share consumer are a bit of a mess which makes the usage messages hard to read. It is trivial to improve and only affects the usage messages. For example: usage: verifiable-share-consumer [-h] --topic TOPIC --group-id GROUP_ID [--max-messages MAX-MESSAGES] [--verbose] [--acknowledgement-mode ACKNOWLEDGEMENTMODE] [--offset-reset-strategy OFFSETRESETSTRATEGY] [--command-config CONFIG_FILE] --bootstrap-server HOST1:PORT1[,HOST2:PORT2[...]] would be better as: usage: verifiable-share-consumer [-h] --topic TOPIC --group-id GROUP-ID [--max-messages MAX-MESSAGES] [--verbose] [--acknowledgement-mode ACKNOWLEDGEMENT-MODE] [--offset-reset-strategy OFFSET-RESET-STRATEGY] [--command-config CONFIG_FILE] --bootstrap-server HOST1:PORT1[,HOST2:PORT2[...]] -- This message was sent by Atlassian Jira (v8.20.10#820010)