cxm940188 opened a new pull request, #23525:
URL: https://github.com/apache/kafka/pull/23525

   
   Fix an off-by-one in `QuorumController.appendRecords` non-atomic batching, 
which appended an empty batch when the record count was a multiple of 
`maxRecordsPerBatch`.
   
   The empty batch is rejected by Raft, causing the active controller to 
renounce leadership and clients to receive `UnknownServerException`.
   
   The loop is now bounded by `startIndex < records.size()`, guaranteeing every 
batch is non-empty.
   


-- 
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.

To unsubscribe, e-mail: [email protected]

For queries about this service, please contact Infrastructure at:
[email protected]

Reply via email to