Hi,

I really like jQuery's API but find the libraries source code
difficult to read.

For example:
- Short var names
- Ommission of braces and heavy use of shorthand if(), for() blocks
- Nested ternary operators, some of which transcend several lines

Does anyone know if there are plans to improve the readability of the
source code going forward? Am I alone in thinking the source code is
difficult to read? (I don't mean it's overall construction, I like
the  methodology, just the fine grain stuff mentioned above)

The main problems I have are that the short var names make it hard to
follow the code and the shorthand block statements make it tedious to
insert logging / debug statements into the core when deconstructing
how something works.

With javascript packers, is it really necessary to have uncompressed
source code like this?

if ( m && (m[1] || !c) ) { ... }

return ( t.constructor == Array || t.jquery )
        ? jQuery.inArray( a, t ) < 0
        : a != t;

Please don't think that I'm having a dig at jQuery here :) I'm just
curious what others think as I find this to be the biggest reason why
I haven't utilised the library on any large scale work as yet.
Essentially, I'm reluctant to rely on a library that I find hard to
read and deconstruct.

Cheers,

Ian

Reply via email to