The syntax you posted is correct, but it doesn't seem to match the error 
you are getting. In the error it complains that there is no ncread method 
with first two arrays and then two strings; because ncread needs first two 
strings and then two integer arrays as you posted.
Can you reproduce this in a fresh julia session? I tried and couldn't 
reproduce. If so it's probably best to submit it as an issue on GitHub 
<>, with as much 
information as possible.
Regarding the documentation, naturally it can be improved, but there are 
examples available here 
<>. And 
by typing ?ncread in the REPL you get documentation on ncread.


On Friday, September 16, 2016 at 3:54:52 PM UTC+2, MLicer wrote:
> Dear all,
> i am trying to read *one* *specific* elevation [Lat x Lon x Time] 
> timestep in a large NetCDF file using Julia NetCDF. I've tried the syntax 
> (along with many variations to the theme):
> timestep = 17
> el=ncread(fname,"elevation",start=[1,1,timestep], count=[-1, -1, 1])
> which returns the following error:
> ERROR: LoadError: MethodError: `__ncread#17__` has no method matching 
> __ncread#17__(::Array{Any,1}, ::Array{Int64,1}, ::ASCIIString, 
> ::ASCIIString)
> Can anyone help me get this right? What is wrong with my syntax? It's very 
> time consuming to read the entire variable just to subset it to one 
> timestep in the next line.
> I appreciate all the work done on the NetCDF.jl package very much, but i 
> feel that documentation (and users) would benefit from some concrete 
> examples like the one i am mentioning.
> Thanks so much!

Reply via email to