I would suggest to start over, but keep REQUIRE file. Then do Pkg.init(), 
put REQUIRE file back and Pkg.update(). 

On Tuesday, September 20, 2016 at 10:07:36 PM UTC+3, J Luis wrote:
>
> Hi,
>
> So I did it again. While trying to install ImageMagick and at same time 
> attempting to convince Julia that I already had one ImageMagick installed 
> in my Win machine and manually deleted some files.
> After that the chaos. Every Pkg.update() has something to complain. For 
> example
>
> julia> Pkg.update()
> INFO: Updating METADATA...
> INFO: Cloning cache of GLVisualize from https://
> github.com/JuliaGL/GLVisualize.jl.git
> ERROR: GitError(Code:ENOTFOUND, Class:Repository, Could not find 
> repository from 'C:\j\.julia\v0.5\.cache\GMT')
>  in Base.LibGit2.GitRepo(::String) at .\libgit2\repository.jl:11
>
> it looks that I have no alternative than to wipe it completely and start a 
> new.
> And, I see that it's still there the (confess, annoyingly fact) that a 
> Pkg.rm() doesn't remove anything but merely moves the "removed" package to 
> the .trash directory.
>
> In such cases, is there anyway to rescue the corrupted .julia?
>
>
>
>

Reply via email to