https://bugs.kde.org/show_bug.cgi?id=525827
--- Comment #1 from [email protected] <[email protected]> --- I deleted all my akonadi data. I reconfigured all. this bug: Akonadi Server Self-Test Report=============================== Test 1: SUCCESS -------- Database driver found. Details: The QtSQL driver 'QMYSQL' is required by your current Akonadi server configuration and was found on your system. File content of '/home/philipp/.config/akonadi/akonadiserverrc': [Debug] Tracer=null [%General] Driver=QMYSQL [QMYSQL] Host= Name=akonadi Options="UNIX_SOCKET=/run/user/1001/akonadi/mysql.socket" ServerPath=/usr/sbin/mysqld-akonadi StartServer=true Test 2: SUCCESS -------- Akonadi is not running as root Details: Akonadi is not running as a root/administrator user, which is the recommended setup for a secure system. Test 3: SUCCESS -------- MySQL server found. Details: You have currently configured Akonadi to use the MySQL server '/usr/sbin/mysqld-akonadi'. Make sure you have the MySQL server installed, set the correct path and ensure you have the necessary read and execution rights on the server executable. The server executable is typically called 'mysqld'; its location varies depending on the distribution. Test 4: SUCCESS -------- MySQL server is executable. Details: MySQL server found: /usr/sbin/mysqld-akonadi Ver 10.6.23-MariaDB-0ubuntu0.22.04.1 for debian-linux-gnu on x86_64 (Ubuntu 22.04) Test 5: SUCCESS -------- MySQL server log contains no errors. Details: The MySQL server log file '<a href="/home/philipp/.local/share/akonadi/db_data/mysql.err">/home/philipp/.local/share/akonadi/db_data/mysql.err</a>' does not contain any errors or warnings. File content of '/home/philipp/.local/share/akonadi/db_data/mysql.err': 2026-09-16 15:30:01 0 [Note] Starting MariaDB 10.6.23-MariaDB-0ubuntu0.22.04.1 source revision fe8047caf26d20e98ea7f6ec1dce3924e696703f server_uid 42P27ukR1CYsgY4vxzsttudhwm0= as process 20167 2026-09-16 15:30:01 0 [Note] InnoDB: Compressed tables use zlib 1.2.11 2026-09-16 15:30:01 0 [Note] InnoDB: Number of pools: 1 2026-09-16 15:30:01 0 [Note] InnoDB: Using crc32 + pclmulqdq instructions 2026-09-16 15:30:01 0 [Note] InnoDB: Using liburing 2026-09-16 15:30:01 0 [Note] InnoDB: Initializing buffer pool, total size = 134217728, chunk size = 134217728 2026-09-16 15:30:01 0 [Note] InnoDB: Completed initialization of buffer pool 2026-09-16 15:30:02 0 [Note] InnoDB: 128 rollback segments are active. 2026-09-16 15:30:02 0 [Note] InnoDB: Creating shared tablespace for temporary tables 2026-09-16 15:30:02 0 [Note] InnoDB: Setting file './ibtmp1' size to 12 MB. Physically writing the file full; Please wait ... 2026-09-16 15:30:02 0 [Note] InnoDB: File './ibtmp1' size is now 12 MB. 2026-09-16 15:30:02 0 [Note] InnoDB: 10.6.23 started; log sequence number 21904888; transaction id 11259 2026-09-16 15:30:02 0 [Note] InnoDB: Loading buffer pool(s) from /home/philipp/.local/share/akonadi/db_data/ib_buffer_pool 2026-09-16 15:30:02 0 [Note] Plugin 'FEEDBACK' is disabled. 2026-09-16 15:30:02 0 [Note] /usr/sbin/mysqld-akonadi: ready for connections. Version: '10.6.23-MariaDB-0ubuntu0.22.04.1' socket: '/run/user/1001/akonadi/mysql.socket' port: 0 Ubuntu 22.04 2026-09-16 15:30:02 0 [Note] InnoDB: Buffer pool(s) load completed at 260916 15:30:02 Test 6: SUCCESS -------- MySQL server default configuration found. Details: The default configuration for the MySQL server was found and is readable at <a href="/etc/xdg//akonadi/mysql-global.conf">/etc/xdg//akonadi/mysql-global.conf</a>. File content of '/etc/xdg//akonadi/mysql-global.conf': # # Global Akonadi MySQL server settings, # These settings can be adjusted using $HOME/.config/akonadi/mysql-local.conf # # Based on advice by Kris Köhntopp <[email protected]> # [mysqld] # strict query parsing/interpretation # TODO: make Akonadi work with those settings enabled # sql_mode=strict_trans_tables,strict_all_tables,strict_error_for_division_by_zero,no_auto_create_user,no_auto_value_on_zero,no_engine_substitution,no_zero_date,no_zero_in_date,only_full_group_by,pipes_as_concat # sql_mode=strict_trans_tables # DEBUGGING: # log all queries, useful for debugging but generates an enormous amount of data # log=mysql.full # log queries slower than n seconds, log file name relative to datadir (for debugging only) # log_slow_queries=mysql.slow # long_query_time=1 # log queries not using indices, debug only, disable for production use # log_queries_not_using_indexes=1 # # measure database size and adjust innodb_buffer_pool_size # SELECT sum(data_length) as bla, sum(index_length) as blub FROM information_schema.tables WHERE table_schema not in ("mysql", "information_schema"); # NOTES: # Keep Innob_log_waits and keep Innodb_buffer_pool_wait_free small (see show global status like "inno%", show global variables) #expire_logs_days=3 #sync_bin_log=0 # Use UTF-8 encoding for tables character_set_server=utf8 collation_server=utf8_general_ci # use InnoDB for transactions and better crash recovery default_storage_engine=innodb # memory buffer InnoDB uses to cache data and indexes of its tables (default:128M) # Larger values means less I/O innodb_buffer_pool_size=128M # Create a .ibd file for each table (default:0) innodb_file_per_table=1 # Write out the log buffer to the log file at each commit (default:1) innodb_flush_log_at_trx_commit=2 # Buffer size used to write to the log files on disk (default:1M for builtin, 8M for plugin) # larger values means less I/O innodb_log_buffer_size=1M # Size of each log file in a log group (default:5M) larger means less I/O but more time for recovery. innodb_log_file_size=64M # # error log file name, relative to datadir (default:hostname.err) log_error=mysql.err # print warnings and connection errors (default:1) loose_log_warnings=2 # Convert table named to lowercase lower_case_table_names=1 # Maximum size of one packet or any generated/intermediate string. (default:1M) max_allowed_packet=32M # Maximum simultaneous connections allowed (default:100) max_connections=256 # The two options below make no sense with prepared statements and/or transactions # (make sense when having the same query multiple times) # Memory allocated for caching query results (default:0 (disabled)) loose_query_cache_size=0 # Do not cache results (default:1) loose_query_cache_type=0 # Do not use the privileges mechanisms skip_grant_tables # Do not listen for TCP/IP connections at all skip_networking # The number of open tables for all threads. (default:64) table_open_cache=200 # How many threads the server should cache for reuse (default:0) thread_cache_size=3 # wait 365d before dropping the DB connection (default:8h) wait_timeout=31536000 # We use InnoDB, so don't let MyISAM eat up memory key_buffer_size=16K # KUBUNTU: # Unset the export dir check as only the full mysql-server package creates it secure_file_priv= # KUBUNTU: # workaround for 5.7 being more strict with column types # (reverts to 5.6 behavior) sql_mode=NO_ENGINE_SUBSTITUTION [client] default-character-set=utf8 Test 7: SKIP -------- MySQL server custom configuration not available. Details: The custom configuration for the MySQL server was not found but is optional. Test 8: SUCCESS -------- MySQL server configuration is usable. Details: The MySQL server configuration was found at <a href="/home/philipp/.local/share/akonadi/mysql.conf">/home/philipp/.local/share/akonadi/mysql.conf</a> and is readable. File content of '/home/philipp/.local/share/akonadi/mysql.conf': # # Global Akonadi MySQL server settings, # These settings can be adjusted using $HOME/.config/akonadi/mysql-local.conf # # Based on advice by Kris Köhntopp <[email protected]> # [mysqld] # strict query parsing/interpretation # TODO: make Akonadi work with those settings enabled # sql_mode=strict_trans_tables,strict_all_tables,strict_error_for_division_by_zero,no_auto_create_user,no_auto_value_on_zero,no_engine_substitution,no_zero_date,no_zero_in_date,only_full_group_by,pipes_as_concat # sql_mode=strict_trans_tables # DEBUGGING: # log all queries, useful for debugging but generates an enormous amount of data # log=mysql.full # log queries slower than n seconds, log file name relative to datadir (for debugging only) # log_slow_queries=mysql.slow # long_query_time=1 # log queries not using indices, debug only, disable for production use # log_queries_not_using_indexes=1 # # measure database size and adjust innodb_buffer_pool_size # SELECT sum(data_length) as bla, sum(index_length) as blub FROM information_schema.tables WHERE table_schema not in ("mysql", "information_schema"); # NOTES: # Keep Innob_log_waits and keep Innodb_buffer_pool_wait_free small (see show global status like "inno%", show global variables) #expire_logs_days=3 #sync_bin_log=0 # Use UTF-8 encoding for tables character_set_server=utf8 collation_server=utf8_general_ci # use InnoDB for transactions and better crash recovery default_storage_engine=innodb # memory buffer InnoDB uses to cache data and indexes of its tables (default:128M) # Larger values means less I/O innodb_buffer_pool_size=128M # Create a .ibd file for each table (default:0) innodb_file_per_table=1 # Write out the log buffer to the log file at each commit (default:1) innodb_flush_log_at_trx_commit=2 # Buffer size used to write to the log files on disk (default:1M for builtin, 8M for plugin) # larger values means less I/O innodb_log_buffer_size=1M # Size of each log file in a log group (default:5M) larger means less I/O but more time for recovery. innodb_log_file_size=64M # # error log file name, relative to datadir (default:hostname.err) log_error=mysql.err # print warnings and connection errors (default:1) loose_log_warnings=2 # Convert table named to lowercase lower_case_table_names=1 # Maximum size of one packet or any generated/intermediate string. (default:1M) max_allowed_packet=32M # Maximum simultaneous connections allowed (default:100) max_connections=256 # The two options below make no sense with prepared statements and/or transactions # (make sense when having the same query multiple times) # Memory allocated for caching query results (default:0 (disabled)) loose_query_cache_size=0 # Do not cache results (default:1) loose_query_cache_type=0 # Do not use the privileges mechanisms skip_grant_tables # Do not listen for TCP/IP connections at all skip_networking # The number of open tables for all threads. (default:64) table_open_cache=200 # How many threads the server should cache for reuse (default:0) thread_cache_size=3 # wait 365d before dropping the DB connection (default:8h) wait_timeout=31536000 # We use InnoDB, so don't let MyISAM eat up memory key_buffer_size=16K # KUBUNTU: # Unset the export dir check as only the full mysql-server package creates it secure_file_priv= # KUBUNTU: # workaround for 5.7 being more strict with column types # (reverts to 5.6 behavior) sql_mode=NO_ENGINE_SUBSTITUTION [client] default-character-set=utf8 Test 9: SUCCESS -------- akonadictl found and usable Details: The program '/usr/bin/akonadictl' to control the Akonadi server was found and could be executed successfully. Result: akonadictl 5.19.3 (21.12.3) Test 10: SUCCESS -------- Akonadi control process registered at D-Bus. Details: The Akonadi control process is registered at D-Bus which typically indicates it is operational. Test 11: SUCCESS -------- Akonadi server process registered at D-Bus. Details: The Akonadi server process is registered at D-Bus which typically indicates it is operational. Test 12: SKIP -------- Protocol version check not possible. Details: Without a connection to the server it is not possible to check if the protocol version meets the requirements. Test 13: SUCCESS -------- Resource agents found. Details: At least one resource agent has been found. Directory listing of '/usr/share/akonadi/agents': akonadiindexingagent.desktop akonotesresource.desktop archivemailagent.desktop birthdaysresource.desktop contactsresource.desktop davgroupwareresource.desktop ewsmtaresource.desktop ewsresource.desktop followupreminder.desktop googleresource.desktop icaldirresource.desktop icalresource.desktop imapresource.desktop kalarmdirresource.desktop kalarmresource.desktop kolabresource.desktop maildirresource.desktop maildispatcheragent.desktop mailfilteragent.desktop mailmergeagent.desktop mboxresource.desktop migrationagent.desktop mixedmaildirresource.desktop newmailnotifieragent.desktop notesagent.desktop notesresource.desktop openxchangeresource.desktop pop3resource.desktop sendlateragent.desktop tomboynotesresource.desktop unifiedmailboxagent.desktop vcarddirresource.desktop vcardresource.desktop Environment variable XDG_DATA_DIRS is set to '/usr/share/plasma:/usr/share/gnome:/home/philipp/.local/share/flatpak/exports/share:/var/lib/flatpak/exports/share:/usr/local/share/:/usr/share/:/var/lib/snapd/desktop' Test 14: SUCCESS -------- No current Akonadi server error log found. Details: The Akonadi server did not report any errors during its current startup. Test 15: SUCCESS -------- No previous Akonadi server error log found. Details: The Akonadi server did not report any errors during its previous startup. Test 16: SUCCESS -------- No current Akonadi control error log found. Details: The Akonadi control process did not report any errors during its current startup. Test 17: SUCCESS -------- No previous Akonadi control error log found. Details: The Akonadi control process did not report any errors during its previous startup. -- You are receiving this mail because: You are watching all bug changes.
