https://bugs.kde.org/show_bug.cgi?id=526284

            Bug ID: 526284
           Summary: KDE Login don't use canonical name
    Classification: Plasma
           Product: plasma-login-manager
      Version First unspecified
       Reported In:
          Platform: KDE Linux
                OS: Linux
            Status: REPORTED
          Severity: normal
          Priority: NOR
         Component: general
          Assignee: [email protected]
          Reporter: [email protected]
                CC: [email protected], [email protected]
  Target Milestone: ---

DESCRIPTION

I logon using my telephone number.
The next time I am greeted, KDE Login Manager hasn't switched my telephone
number with my Linux (canonical) user id.

STEPS TO REPRODUCE

1. Use custom PAM/NSS module supporting login using phone number, e-mail etc.
2. Login using anything else then your user id
3. Reboot/Logout and see that KDE Login Manager isn't showing the canonical
user id

OBSERVED RESULT

KDE Login Manager doesn't seem to catch the canonical user id returned from the
PAM module during login.

EXPECTED RESULT

KDE Login Manager show my user id, instead of my phone number.

SOFTWARE/OS VERSIONS

Operating System: KDE Linux 202608290254
KDE Plasma Version: 6.7.80
KDE Frameworks Version: 6.30.0
Qt Version: 6.11.2
Kernel Version: 7.1.10-arch1-1 (64-bit)
Graphics Platform: Wayland
Processors: 8 × Intel® Core™ i5-10210U CPU @ 1.60GHz
Memory: 32 GB of RAM (31,0 GB usable)
Graphics Processor: Intel® UHD Graphics
Manufacturer: HP
Product Name: HP 260 G4 Desktop Mini PC

ADDITIONAL INFORMATION

I have this `/etc/pam.d/system-auth` file:

```
#%PAM-1.0

-account      [success=1 default=ignore]      pam_systemd_home.so
account       sufficient                      pam_mkhomedir.so
account       sufficient                      libnss_rpc_repository.so
account       required                        pam_unix.so
account       optional                        pam_permit.so
account       required                        pam_time.so

auth          required                        pam_faillock.so              
preauth
-auth         [success=2 default=ignore]      pam_systemd_home.so
auth          sufficient                      pam_mkhomedir.so
auth          [success=2 default=ignore]      libnss_rpc_repository.so
auth          [success=1 default=bad]         pam_unix.so                  
try_first_pass nullok nodelay
auth          [default=die]                   pam_faillock.so              
authfail
auth          optional                        pam_permit.so
auth          required                        pam_env.so
auth          required                        pam_faillock.so              
authsucc
auth          optional                        pam_faildelay.so             
delay=0

-password     [success=1 default=ignore]      pam_systemd_home.so
password      sufficient                      pam_mkhomedir.so
password      sufficient                      libnss_rpc_repository.so
password      required                        pam_unix.so                  
try_first_pass nullok nodelay shadow
password      optional                        pam_permit.so

-session      optional                        pam_systemd_home.so
session       optional                        pam_mkhomedir.so
session       required                        pam_limits.so
session       optional                        libnss_rpc_repository.so
session       required                        pam_unix.so
session       optional                        pam_kwallet5.so              
auto_start kwalletd=/usr/bin/ksecretd
session       optional                        pam_permit.so
```

-- 
You are receiving this mail because:
You are watching all bug changes.

Reply via email to