https://bugs.kde.org/show_bug.cgi?id=383211

--- Comment #6 from Thomas Schmitt <scdbac...@gmx.net> ---
Hi,

> I experienced Brain spasm [...]
> I feel really difficult to read and write English

Go see a doctor. A good one, who does what is needed, not just what he can.


> please give me some hint about how to get the correct
> MediaSizeBluRay25Gb/MediaSizeBluRay50Gb value before the buring job.

Let's look for occurences. Since i don't see a code search facility
in k3b.git, i use the Debian source tree (which might be a bit outdated):

  https://codesearch.debian.net/search?q=package%3Ak3b+MediaSizeBluRay25Gb

which yields:

--------------------------------------------------------------------------

 
http://sources.debian.net/src/k3b/2.0.3a-2/src/projects/k3bfillstatusdisplay.cpp/?hl=729#L729

Here MediaSizeBluRay25Gb is used to detect the media type.
The value to which it gets compared stems from
  KConfigGroup c.readEntry( "default media size", 0 );
For now i assume, that this function returns one of the sizes from the
list where MediaSizeBluRay25Gb is defined.

--------------------------------------------------------------------------

 
http://sources.debian.net/src/k3b/2.0.3a-2/src/projects/k3bfillstatusdisplay.cpp/?hl=373#L373
 
http://sources.debian.net/src/k3b/2.0.3a-2/src/projects/k3bfillstatusdisplay.cpp/?hl=375#L375

seems to set the displayed size to a caller defined value.
(I riddle about the combination of exact sizes like MediaSizeDvd4Gb
 and naive values like 2306867. A normal single layer DVD has 2295104
 blocks. DVD-RAM has less.)

--------------------------------------------------------------------------

 
http://sources.debian.net/src/k3b/2.0.3a-2/src/projects/k3bfillstatusdisplay.cpp/?hl=585#L585

I really wonder where the value set by this function is used.

--------------------------------------------------------------------------

 
http://sources.debian.net/src/k3b/2.0.3a-2/src/projects/k3bfillstatusdisplay.cpp/?hl=822#L822

seems to set the displayed size to one of the defined sizes,
depending on media type and d->doc->length().lba().
The type of "d" is somewhere in the C++ spaghetti definitions.
It seems to be a class which describes some device aspects.
(Zorry, i am an old C programmer. Maybe we need a C++ expert.)

------------------------------------------------------------------

All in all the symbols MediaSizeBluRay25Gb and MediaSizeBluRay50Gb
seem not to be used for internal program control purposes but rather
for display only. (I can be wrong. Better check yourself, too.)

If so, then the change should beautify the user interface but not
trigger decisions whether the intended data fit on the loaded media.

So: The patch proposal looks good to me.


Have a nice day :)

Thomas

-- 
You are receiving this mail because:
You are watching all bug changes.

Reply via email to