--- Comment #6 from ---

Summery: writing metadata to the same jpg files on the local drive worked, but
the images broke on the smb share from the nas.

I ran the digikam5.9.0 diskimage, I copied a set of the same photos from the
naz to a local folder. Then after a few crashes trying to get digikam to add
the local folder the photos loaded. I tried adding tags, labels, star ratings
and rotating the images (I had already change digikams settings to write
metadata to file). All seamed to work fine and the jpg images were undamaged. I
then opened some other applications to use up all the RAM on the system in the
same way it was when I had the problem before. However everything worked and
the images were still ok. I did not test with other images of different types
or from other cameras, etc as I was unable to replicate the problem in 5.9.0
with data on the local drive.

The nas and its drives are only 3 months old. The PC running ubuntu is about 6
years old but its internal drive is only 2 years old as it was upgraded to use
an ssd. So the disks on both systems should be in good condition.
The jpg photos which broke however have been moved between quite a few drives
and locations since 2013 when they were taken.
The console output can be accessed at the same location as the sample images:

Next I copied another set of the original files that are on the nas smb share
to a new folder also on the nas and added them into digikam. I tried adding
tags, metadata and star ratings. The problem came back and the images this time
were sometimes completely empty of data and some had part or all of the data
written. The console output file has also been uploaded.

I guess this might not be a digikam bug if this happens only when images are
accessed over an smb share? Currently I'm not able to test if this problem
still happens if I switch to an AFP or NFS share. The NAS is new and quite
powerful with 8GB of ram.

You are receiving this mail because:
You are watching all bug changes.

Reply via email to