--- Comment #11 from Alois Steindl <> ---
Thanks for your efforts.

The error can be triggered quite simply: First make sure, that samba server is
running and there is a workgroup.

Simply open dolphin and click on Network -> Samba Shares.
(I am using a german environment, so the names might be slightly different).
Using journalctl -f one sees the lines
kioslave: ######CRASH ###### protocol = smb pid = 17509 signal = 11.
Having run dolphin longer, there are repeating such lines, with pid increasing
by 5-10 in every step.
In the address line "smb://" is displayed.
If I change that to smb://WORKGROUP, I get the message, that some internal
error occured and one should file a bug report.

Repeating the step, I obtain the message, that the file smb://user@WORKGROUP/
doesn't exist. Nothing is displayed by journalctl.
If I enter the name of a non-existent Workgroup, I get the (correct) message,
that it cannot connect to smb://wrongWORKGROUPname/

In order to ensure, that there is no silly mistake in some configuration file
on my computer, I moved ~/.kde to ~/.kde-save; the behaviour remained the same.
I also downloaded the Fedora 26 and 27 Live-system isos and tried these on a
different computer. With Fedora 26 it behaved properly (Clicking on Samba share
displayed the WORKGROUP, and I could dig deeper into the tree.)
With Fedora 27 I got the same behaviour as described above. 

Sometimes it happened, that I was asked for credentials and dolphin tried to
connect to smb://username@WORKGROUP, which of course also failed.

Fortunately the error doesn't prevent serious work. If I try to connect to a
specific samba share, it works correctly.

You are receiving this mail because:
You are watching all bug changes.

Reply via email to