--- Comment #12 from A. Wilcox (awilfox) <> ---
Completely unrelated.  I'm using libepoxy 1.4.3.  In fact, here's an exact
version of every relevant package on this system (and yes, this is still
happening every time I run ffplay):

* Qt 5.9.3, vanilla, unpatched
* Plasma Workspace/Desktop 5.12.2 LTS, vanilla, unpatched
* Mesa 17.3.1, with a patch to make the build system use Python 3, and another
patch to fix a stack overflow in disk_cache
* libepoxy 1.4.3, vanilla, unpatched
* X.Org Server 1.19.6, with a single unrelated patch related to musl on ARM
(this is an x86_64 system)
* xf86-video-amdgpu 1.4.0, vanilla, unpatched
* Linux kernel 4.14.19, mc patchset, otherwise unpatched

They're distro packages, but I'm the distro maintainer, and I run the build
servers, so I'm confident enough this is close enough to "compiled sources".

In fairness, the /segmentation fault/ isn't really KDE's fault; Qt Declarative
sucks bad.  It does a lot of unsafe things in its atexit handlers that it
REALLY should not do.  However, the only reason exit() is called is because of
an interaction between Plasma's BlurEffect dtor and libepoxy.  Which one is the
culprit, I don't know, but I do know that the issue/patch
(a8c3faaa1990d98047e3c566409200604105fa9c) is not relevant to this issue, for
many reasons:

* this is open source amdgpu
* amd, not nvidia
* 1.4.3, not 1.5.0
* epoxyinfo don't crash here

You are receiving this mail because:
You are watching all bug changes.

Reply via email to