Bug ID: 369105
           Summary: KDevelop-5.0.1 AppImage doesn't launch on Gentoo
                    because of " error: symbol lookup
           Product: kdevelop
           Version: unspecified
          Platform: Appimage
                OS: Linux
            Status: UNCONFIRMED
          Severity: normal
          Priority: NOR
         Component: general

I use Gentoo/Linux and I have installed KDevelop-5.0.1 with a custom ebuild an
works like a charm. Although I wanted to download and test an AppImage with the
same version from here:

For some reason *this* KDevelop executable (appimage) can't launch and rants
about " /usr/lib64/ error: symbol lookup error: undefined
symbol: xcb_send_request_with_fds ". I am providing one URL with the output of

LD_DEBUG=”libs” && ./KDevelop-5.0.1-x86_64.AppImage 

and onother of the command:

LD_DEBUG=”files” && ./KDevelop-5.0.1-x86_64.AppImage which is :

Let me tell you that I tried the same appimage with Arch and worked right away.
Also I haven't had any problem with AppImage version 5.0.0-1. Just this 5.0.1

So what is missing? Should I provide more debug-info about the system-installed

Reproducible: Always

Steps to Reproduce:
1. download from
2. make the appimage executable and run it
3. crash

Actual Results:  
kdevelop: symbol lookup error: /usr/lib64/ undefined symbol:

Expected Results:  
Launch the application

I am using software compiled with -ggdb and splitdebug for proper bug
reporting. Don't think it matters to the problem though.

You are receiving this mail because:
You are watching all bug changes.

Reply via email to