Bug ID: 370998
           Summary: the python interfaces to KApplication and
                    KConfigSkeleton stopped working with sip 4.18
           Product: bindings
           Version: 4.12.3
          Platform: Kubuntu Packages
                OS: Linux
            Status: UNCONFIRMED
          Severity: grave
          Priority: NOR
         Component: pykde

The attached scripts work fine with Kubuntu 16.04 but not with 16.10. They
crash but drkonqi does not give useful information. I am attaching part of
valgrind output.

If I install the packages python-qt4 and python-sip from 16.04 on 16.10, they
If I install the packages python-qt4 and python-sip from 16.10 on 16.04, they
do not work.

But I cannot reproduce any bugs without using pykde.

This means kajongg does no longer run on Kubuntu using PyKDE4. However it can
emulate most of what it needs from PyKDE4 when started with --nokde. I will
have to commit a change which lets kajongg always run with --nokde until this
bug is fixed.

Reproducible: Always

Steps to Reproduce:
1. python2 ; python2

Actual Results:  

Expected Results:  
no segfault

You are receiving this mail because:
You are watching all bug changes.

Reply via email to