anthonyfieroni added inline comments.

INLINE COMMENTS

> extractor.cpp:39-46
> +    if (d) {
> +        if (d->m_pluginLoader.isLoaded()) {
> +            d->m_pluginLoader.unload();
> +        } else {
> +            delete d->m_plugin;
> +        }
> +    }

Make a method to call it, here and in destructor to not have duplicate code.
Other looks good to me +1.

REPOSITORY
  R286 KFileMetaData

REVISION DETAIL
  https://phabricator.kde.org/D7750

To: mgallien, #frameworks
Cc: anthonyfieroni

Reply via email to