ervin requested changes to this revision.
ervin added a comment.
This revision now requires changes to proceed.


  Couple more changes needed.

INLINE COMMENTS

> kfileplacesmodel.cpp:79-83
> +//static const QHash<KFilePlacesModel::GroupType, QString> 
> s_groupTypeToStateName
> +//{
> +//    return *s_groupTypeToStateName;
> +//}
> +

This can go away now

> kfileplacesmodel.h:71-72
>      bool isHidden(const QModelIndex &index) const;
> +    bool isPlaceGroupHidden(const GroupType type) const;
> +    bool isPlaceGroupHidden(const QModelIndex &index) const;
>      bool isDevice(const QModelIndex &index) const;

Just realized now that it'd better be named "isGroupHidden". Otherwise it'll 
get confusing (especially since one of the types is "PlacesType"!)

> kfileplacesmodel.h:89
>      void setPlaceHidden(const QModelIndex &index, bool hidden);
> +    void setPlaceGroupHidden(const GroupType type, bool hidden);
>  

Likewise: setGroupHidden.

REVISION DETAIL
  https://phabricator.kde.org/D8367

To: mlaurent, renatoo, ngraham, franckarrecot, ervin
Cc: ngraham, mlaurent, #frameworks

Reply via email to