bruns added inline comments.

INLINE COMMENTS

> michaelh wrote in fileindexscheduler.cpp:148
> I suppose developers on my level will appreciate code to be most 
> self-explanatory. I'm not objecting though, we might al well go "all the way":
> 
>   list.erase(std::remove_if(list.begin(), list.end(), [&dir](const QString& 
> file) {
>           return file.startsWith(dir);
>       }), list.end());

Following Qt coding style, the `[] () {` should go on a separate line, as 
written above

I think having list.erase as a separate statement makes reading simpler.

REPOSITORY
  R293 Baloo

REVISION DETAIL
  https://phabricator.kde.org/D12233

To: michaelh, #baloo
Cc: bruns, #frameworks, ashaposhnikov, michaelh, astippich, spoorun, ngraham

Reply via email to