sredman accepted this revision.
sredman added a comment.
This revision is now accepted and ready to land.


  I noticed a couple of places where the cmake file could be simplified so make 
those changes and then let's land this monster

INLINE COMMENTS

> CMakeLists.txt:76
> +if (NOT WIN32)
> +    if (ANDROID)
> +        find_package(Qt5 ${REQUIRED_QT_VERSION} CONFIG REQUIRED 
> AndroidExtras)

Move this `if(Android)` block up to where the other *Extras are, lines 63-68 
(then remove the connected `else` and then fix the indenting)

> CMakeLists.txt:98
> +    endif()
> +else()
> +    find_package(LibSnoreToast REQUIRED)

Logically this `else` is pretty separate from the `if` that it is connected to. 
Could you change it to `if(NOT WIN32)` to make it easier to read?

REPOSITORY
  R289 KNotifications

BRANCH
  arcpatch-D21661

REVISION DETAIL
  https://phabricator.kde.org/D21661

To: brute4s99, broulik, sredman, vonreth, albertvaka
Cc: nicolasfella, pino, kde-frameworks-devel, LeGast00n, michaelh, ngraham, 
bruns

Reply via email to